summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-08 19:04:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-08 19:04:39 +0100
commitd7443e05892e21953f2476002a87f3c0213706bb (patch)
treebdc943e4106bc2c6f20218650cf96563b88f1827 /kde-apps/kdepim-addons
parentsys-fs/zfs: drop old (diff)
downloadgentoo-d7443e05892e21953f2476002a87f3c0213706bb.tar.gz
gentoo-d7443e05892e21953f2476002a87f3c0213706bb.tar.bz2
gentoo-d7443e05892e21953f2476002a87f3c0213706bb.zip
kde-apps: Add KDE Applications 17.12.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'kde-apps/kdepim-addons')
-rw-r--r--kde-apps/kdepim-addons/Manifest1
-rw-r--r--kde-apps/kdepim-addons/kdepim-addons-17.12.3.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/kde-apps/kdepim-addons/Manifest b/kde-apps/kdepim-addons/Manifest
index 3775413f0eac..f9319b6b1bcb 100644
--- a/kde-apps/kdepim-addons/Manifest
+++ b/kde-apps/kdepim-addons/Manifest
@@ -1,2 +1,3 @@
DIST kdepim-addons-17.08.3.tar.xz 1922800 BLAKE2B e447a79571e476d68e221d3d1971bfb3ab5437246339462697ac9b748072f0d6836c025197a6aa642086b233ae43f014bd75dbb16d0a207c7b6f928a8117d5ca SHA512 e9411aae9fe401bff73b8bb4c947d1bf8e405760c51479a12a407171dff27081195552204b353da2f555a8c8960f3860bb03f0fa73ba7762a7d36770e209a721
DIST kdepim-addons-17.12.2.tar.xz 2039160 BLAKE2B 1004ef17c46000e2b7385e4213efbd9afa85f8a739848aaf2ac828b5c09b25b38063d924b47581d201bbf7da990e44f81a16ee8a8b54421645a2dfa43e3dbc07 SHA512 3caceb92bc549d91d1201f711539317ccdfd7160669eed2a94b67df474b6cc760a31dad682d0ef0429926e4c7a43acf822d2b7b72535194567d6efe2a1037ee3
+DIST kdepim-addons-17.12.3.tar.xz 2038588 BLAKE2B 76636629c40b81afa4cd6bdf273ea250e196247e2673365dbfb768c76449b01a72ad80af277bb03e31302b4ba8643f5d783b9c05aa62dea8b8eba1effce8a68f SHA512 15e15f5a7a00db274f1ac643d03b41cb71949ad7c36d35c19a011d2704b887dd1f23e78dd6f8ef04852a7934e5e5361fe0a60c93e17b2c891d55baeee75352f2
diff --git a/kde-apps/kdepim-addons/kdepim-addons-17.12.3.ebuild b/kde-apps/kdepim-addons/kdepim-addons-17.12.3.ebuild
new file mode 100644
index 000000000000..5a11e4f931dd
--- /dev/null
+++ b/kde-apps/kdepim-addons/kdepim-addons-17.12.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_EXAMPLES="true"
+KDE_TEST="forceoptional-recursive"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plugins for KDE Personal Information Management Suite"
+HOMEPAGE="https://www.kde.org/applications/office/kontact/"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="importwizard"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep prison)
+ $(add_frameworks_dep syntax-highlighting)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep eventviews)
+ $(add_kdeapps_dep grantleetheme)
+ $(add_kdeapps_dep incidenceeditor)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kdepim-apps-libs)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep libkdepim)
+ $(add_kdeapps_dep libkleo)
+ $(add_kdeapps_dep libksieve)
+ $(add_kdeapps_dep libktnef)
+ $(add_kdeapps_dep mailcommon)
+ $(add_kdeapps_dep messagelib)
+ $(add_kdeapps_dep pimcommon)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ importwizard? ( $(add_kdeapps_dep akonadi-import-wizard) )
+"
+DEPEND="${COMMON_DEPEND}
+ >=app-crypt/gpgme-1.7.1[cxx,qt5]
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kaddressbook:4
+ !kde-apps/kdepim-l10n
+ !kde-apps/kmail:4
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DKDEPIMADDONS_BUILD_EXAMPLES=$(usex examples)
+ $(cmake-utils_use_find_package importwizard KPimImportWizard)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ ${KDE_BUILD_TYPE} = live ]] && ! has_version "kde-misc/kregexpeditor" ; then
+ elog "${PN} Sieve editor plugin can make use of kde-misc/kregexpeditor if installed."
+ fi
+}