summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-08-02 11:34:12 -0700
committerYixun Lan <dlan@gentoo.org>2024-08-11 01:46:25 +0000
commitc80bcb9bf1d17f8ee2f72af8fe41aebf6ab8c2df (patch)
treece8fcc2c2786807e0166124324d06ecd1740d460 /gui-libs
parentgui-libs/aquamarine: fix dependencies (diff)
downloadgentoo-c80bcb9bf1d17f8ee2f72af8fe41aebf6ab8c2df.tar.gz
gentoo-c80bcb9bf1d17f8ee2f72af8fe41aebf6ab8c2df.tar.bz2
gentoo-c80bcb9bf1d17f8ee2f72af8fe41aebf6ab8c2df.zip
gui-libs/aquamarine: add 0.2.0
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/aquamarine/Manifest1
-rw-r--r--gui-libs/aquamarine/aquamarine-0.2.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/gui-libs/aquamarine/Manifest b/gui-libs/aquamarine/Manifest
index f3b2ca57f389..648a4ccb8f16 100644
--- a/gui-libs/aquamarine/Manifest
+++ b/gui-libs/aquamarine/Manifest
@@ -1 +1,2 @@
DIST aquamarine-0.1.1.tar.gz 70241 BLAKE2B 511e03fed61f970b6309f4cc630e6cfee9eabb4b2d95da27699aa9b38e8e20922847272c9bb4467fb59f428b7137196be2e31cf4e34ac0bb61df5e1520c6f27a SHA512 5e51db094d8a30b53f6bd0e8895039adb354f04428c49e6d1b6fdbbc13d9e8ee02d42da1f9d78bb495a0cd8e286888323a5dbdf663ae6df7495072ed6ab4abc2
+DIST aquamarine-0.2.0.tar.gz 71350 BLAKE2B d44df5f3785f381e86e05617741c114be5b3a29dda9995e84853c35753ddbac55f2f59ec4e1074829c2eb60439469b89eb0ffa6ebe98193d3bea2c975a033767 SHA512 2665ecb764f374f22a6cda88b6ede09e48ba76c245b9922a41daa13eed2c0eca51915a553829d4c9ee22d5b84c2ff9af6b8672908ad7c2f3d6d4838437c53de0
diff --git a/gui-libs/aquamarine/aquamarine-0.2.0.ebuild b/gui-libs/aquamarine/aquamarine-0.2.0.ebuild
new file mode 100644
index 000000000000..ae50cc1d99ca
--- /dev/null
+++ b/gui-libs/aquamarine/aquamarine-0.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Aquamarine is a very light linux rendering backend library"
+HOMEPAGE="https://github.com/hyprwm/aquamarine"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/wayland
+ media-libs/mesa[opengl]
+ media-libs/libdisplay-info
+ >=dev-libs/libinput-1.26.1
+ >=dev-util/hyprwayland-scanner-0.4.0
+ >=gui-libs/hyprutils-0.1.5
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/libdrm
+ x11-libs/pango
+ x11-libs/pixman
+ virtual/libudev
+ sys-apps/hwdata
+ >=sys-auth/seatd-0.8.0
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i "/add_compile_options(-O3)/d" "${S}/CMakeLists.txt" || die
+ cmake_src_prepare
+}