summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2025-01-26 13:12:43 +0100
committerPacho Ramos <pacho@gentoo.org>2025-01-26 16:00:34 +0100
commit5c957d2712da07b5f93c5766a5586e9386aa4fb3 (patch)
tree20479c5cd2d81e9bd4b33c7607039001fef78056 /gui-libs
parentx11-libs/vte: add 0.78.3 (diff)
downloadgentoo-5c957d2712da07b5f93c5766a5586e9386aa4fb3.tar.gz
gentoo-5c957d2712da07b5f93c5766a5586e9386aa4fb3.tar.bz2
gentoo-5c957d2712da07b5f93c5766a5586e9386aa4fb3.zip
gui-libs/vte-common: add 0.78.3
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/vte-common/Manifest1
-rw-r--r--gui-libs/vte-common/vte-common-0.78.3.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/gui-libs/vte-common/Manifest b/gui-libs/vte-common/Manifest
index 318d686aaf38..b13b9d0ba061 100644
--- a/gui-libs/vte-common/Manifest
+++ b/gui-libs/vte-common/Manifest
@@ -1,2 +1,3 @@
DIST vte-0.74.2.tar.bz2 505422 BLAKE2B 243eabfb26c0ec65d0b202437ae79265440256941dae4263e9d6dc9afea24d0fbbd7d421864a90b54d2ba953cd60a2b5a41aef9fb9e53396176bcc71400eef82 SHA512 203dd0f8606b8979cde01781412e0dbab3cb8857828e55f6d69ecfc2e4d58d53430aa5c61a2203e122c772ba1f6c5b739d3c03456b133580e76d511d67f3f534
DIST vte-0.76.3.tar.bz2 564747 BLAKE2B 1ad65a18ca1aa2371dd74ef3ebaf1aa44358c4a1cbcfa39296fde10e03a76cdbdd2ca7f229f1b4507016e8b986824407d937952a45306eab5e6c0ca5ee9cec8b SHA512 8b7e18831e99ac92159f7b39c6404879cebf22f1f2dcb3feb38cad61f374767f631923c219e153551e9f30ee75c1e8e975fbbf3a6027b9c62ba4f948e3c9f199
+DIST vte-0.78.3.tar.xz 577420 BLAKE2B 273702dede11b0a6dba6bcc8fb1fe7d4fdf3b5194128e39a5e8c285139afb363676e9be6b2e6642f5f6924928b1aeeabd045ddd9f606a14340ea069a2c7d4aeb SHA512 364729996dd0f6e491f7ffbe342db92d9f9822c6c4468265269fcfbc324e0e2c66f75107f9653b161fe4e97755c4092571b29ded963f9c00189bcbb443b5f187
diff --git a/gui-libs/vte-common/vte-common-0.78.3.ebuild b/gui-libs/vte-common/vte-common-0.78.3.ebuild
new file mode 100644
index 000000000000..1f6ab55f72e6
--- /dev/null
+++ b/gui-libs/vte-common/vte-common-0.78.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+GNOME_ORG_MODULE="vte"
+
+inherit flag-o-matic gnome.org meson python-any-r1
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/vte"
+
+S="${WORKDIR}/vte-${PV}"
+
+# Once SIXEL support ships (0.66 or later), might need xterm license (but code might be considered upgraded to LGPL-3+)
+LICENSE="LGPL-3+ GPL-3+"
+
+SLOT="2.91" # vte_api_version in meson.build
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="systemd"
+
+DEPEND="
+ || ( >=gui-libs/gtk-4.0.1:4 >=x11-libs/gtk+-3.24.22:3 )
+ >=x11-libs/cairo-1.0
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.60:2
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21
+ systemd? ( >=sys-apps/systemd-220:= )
+ >=app-arch/lz4-1.9
+ x11-libs/pango
+"
+RDEPEND="
+ !<x11-libs/vte-0.70.0:2.91
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ use elibc_musl && eapply "${FILESDIR}"/${PN}-0.70.0-musl-W_EXITCODE.patch
+}
+
+src_configure() {
+ # Upstream don't support LTO & error out on it in meson.build (bug #926156)
+ filter-lto
+
+ local emesonargs=(
+ -Da11y=false
+ -Ddebug=false
+ -Ddocs=false
+ -Dgir=false
+ -Dfribidi=true # pulled in by pango anyhow
+ -Dglade=false
+ -Dgnutls=false
+ -Dgtk3=false
+ -Dgtk4=false
+ -Dicu=false
+ $(meson_use systemd _systemd)
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ exeinto /usr/libexec/
+ doexe "${BUILD_DIR}"/src/vte-urlencode-cwd
+ insinto /etc/profile.d/
+ newins "${BUILD_DIR}"/src/vte.sh vte-${SLOT}.sh
+ newins "${BUILD_DIR}"/src/vte.csh vte-${SLOT}.csh
+ if use systemd; then
+ insinto /usr/lib/systemd/user/vte-spawn-.scode.d/
+ newins "${S}"/src/vte-spawn-.scope.conf defaults.conf
+ fi
+ einstalldocs
+}