summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-12-01 23:00:33 +0100
committerPacho Ramos <pacho@gentoo.org>2020-12-01 23:15:20 +0100
commit277abc59a10fa7214930d0eac40aef2a45af8ffe (patch)
treec6ff1dc26bbee1852335120881a4cae1c1324661 /gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-34.ebuild
parentgnome-extra/gnome-shell-extension-gsconnect: Bump to v44 (diff)
downloadgentoo-277abc59a10fa7214930d0eac40aef2a45af8ffe.tar.gz
gentoo-277abc59a10fa7214930d0eac40aef2a45af8ffe.tar.bz2
gentoo-277abc59a10fa7214930d0eac40aef2a45af8ffe.zip
gnome-extra/gnome-shell-extension-appindicator: Bump to v34
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-34.ebuild')
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-34.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-34.ebuild b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-34.ebuild
new file mode 100644
index 000000000000..933325eeb279
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-34.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Support Ubuntu AppIndicators and KStatusNotifierItems in Gnome"
+HOMEPAGE="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+SRC_URI="https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ dev-libs/libappindicator:3
+ >=gnome-base/gnome-shell-3.34
+"
+DEPEND=""
+BDEPEND=""
+
+src_compile () { :; }
+
+src_install() {
+ einstalldocs
+ dodoc AUTHORS.md
+ rm -f AUTHORS.md LICENSE Makefile README.md || die
+
+ insinto /usr/share/gnome-shell/extensions/appindicatorsupport@rgcjonas.gmail.com
+ doins -r *
+}
+
+pkg_postinst() {
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}