summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-12-15 23:00:40 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-15 23:00:40 +0200
commit79fa26e00e7a50f89ac867730d116ee566cdee6d (patch)
tree8b65f2be75de9a9e07b8a2226b7d43750b6950ca /games-strategy
parentsci-electronics/freehdl: treeclean (diff)
downloadgentoo-79fa26e00e7a50f89ac867730d116ee566cdee6d.tar.gz
gentoo-79fa26e00e7a50f89ac867730d116ee566cdee6d.tar.bz2
gentoo-79fa26e00e7a50f89ac867730d116ee566cdee6d.zip
games-strategy/defcon-demo: treeclean
Closes: https://bugs.gentoo.org/753515 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/defcon-demo/Manifest2
-rw-r--r--games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild96
-rw-r--r--games-strategy/defcon-demo/files/defcon15
-rw-r--r--games-strategy/defcon-demo/metadata.xml11
4 files changed, 0 insertions, 124 deletions
diff --git a/games-strategy/defcon-demo/Manifest b/games-strategy/defcon-demo/Manifest
deleted file mode 100644
index ba927fc8d8c9..000000000000
--- a/games-strategy/defcon-demo/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST defcon_1.6-1_amd64.deb 62377900 BLAKE2B ad6047a5f57492facf17da50a9d3003181d4352eebaa08e7185a676b3dcfb8a2c3d1001c96c09ae417d482b3a97894032084ede22f841516b9f67ed014861743 SHA512 b71aacc3cd94eec8f1ea19ee03d8098fcdd96191c12d614f55076826ef0bb44c8ada66dfd3df7d94d042b33bdd8fa5f0f58e69fc980d6213c320ab4ce2d682a9
-DIST defcon_1.6-1_i386.deb 62311684 BLAKE2B 3dddd5495410dc875d4ac9ecaea26cbbf2cb258ccdf0ffe0ddb7234009b7986c1ebcb17bdef93a579db8b41eeefaeecea9ebb09bcdb049bee14c0b6af6df26c7 SHA512 0e60e8fbca2f3046228b656990e3adb471de4f64a99d435c96b1e5a8cc49b1250c48ceeb19a4bcb58354e750398de2559256d26a38b20286dec3c0ce7f97ebb8
diff --git a/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild b/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild
deleted file mode 100644
index 123c3f6c0bef..000000000000
--- a/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit desktop toolchain-funcs gnome2-utils
-
-MY_PN=defcon
-MY_PV=${PV:0:3}
-MY_PVR=1
-MY_P=defcon_${MY_PV}-${MY_PVR}
-
-DESCRIPTION="Global thermonuclear war simulation with multiplayer support"
-HOMEPAGE="http://www.introversion.co.uk/defcon/"
-SRC_URI="x86? ( http://www.introversion.co.uk/defcon/downloads/${MY_P}_i386.deb )
- amd64? ( http://www.introversion.co.uk/defcon/downloads/${MY_P}_amd64.deb )"
-
-LICENSE="Introversion"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE="+system-libs"
-RESTRICT="bindist mirror strip"
-
-# glibc discussion:
-# http://forums.introversion.co.uk/defcon/viewtopic.php?t=4016
-RDEPEND="
- media-libs/libogg
- media-libs/libvorbis
- >=sys-libs/glibc-2.3
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libXext
- system-libs? ( media-libs/libsdl[sound,video] )"
-
-QA_PREBUILT="/opt/${PN}/lib/${MY_PN}.bin.x86"
-
-S="${WORKDIR}/usr/local/games/${MY_PN}"
-
-src_unpack() {
- default
- unpack ./data.tar.gz
-
- cd "${S}" || die
- # maintain compatibility with old installation/script
- [[ -e lib64 ]] && { mv lib64 lib || die ;}
- [[ -e ${MY_PN}.bin.x86_64 ]] && { mv ${MY_PN}.bin.x86_64 ${MY_PN}.bin.x86 || die ;}
-}
-
-src_prepare() {
- default
-
- # FindPath scripts are ugly and unnecessary
- if use system-libs ; then
- rm -f lib/lib*
- fi
- sed \
- -e "s:GAMEDIR:/opt/${PN}:g" \
- "${FILESDIR}"/${MY_PN} > "${T}"/${MY_PN} || die
- echo "int chdir(const char *d) { return 0; }" > chdir.c || die
-}
-
-src_compile() {
- echo "$(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c"
- $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c || die
-}
-
-src_install() {
- local dir=/opt/${PN}
-
- insinto ${dir}/lib
- doins *.dat
-
- exeinto ${dir}/lib
- doexe lib/*.so
- doexe ${MY_PN}.bin.x86
-
- doicon -s 128 ${MY_PN}.png
-
- # Can be upgraded to full version, so is not installed as "demo"
- dobin "${T}"/${MY_PN}
- make_desktop_entry ${MY_PN} "Defcon"
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- elog "Screenshots will appear in ~/.${MY_PN}/lib"
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-strategy/defcon-demo/files/defcon b/games-strategy/defcon-demo/files/defcon
deleted file mode 100644
index 6e9dd3b5307c..000000000000
--- a/games-strategy/defcon-demo/files/defcon
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-if [ -n "GAMEDIR/lib" ] ; then
- if [ "${LD_LIBRARY_PATH+set}" = "set" ] ; then
- export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:GAMEDIR/lib"
- else
- export LD_LIBRARY_PATH="GAMEDIR/lib"
- fi
-fi
-if [[ ! -e ~/.defcon/lib ]] ; then
- mkdir -p ~/.defcon/lib \
- && cd ~/.defcon/lib \
- && ln -s "GAMEDIR"/lib/* .
-fi
-cd ~/.defcon/lib
-LD_PRELOAD="GAMEDIR/lib/chdir.so" exec ./defcon.bin.x86 "$@"
diff --git a/games-strategy/defcon-demo/metadata.xml b/games-strategy/defcon-demo/metadata.xml
deleted file mode 100644
index 1c10554c2f51..000000000000
--- a/games-strategy/defcon-demo/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <use>
- <flag name="system-libs">Use system libraries instead of the ones included in the upstream distribution.</flag>
- </use>
-</pkgmetadata>