summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-30 19:40:01 +0100
committerSam James <sam@gentoo.org>2021-06-30 19:40:01 +0100
commit40c751e9ebb33ae439d7513bc8ac7fbd72da6202 (patch)
tree9fe137e9eb8b6b325636f56d54e5dadd8165c28b /games-server
parentgames-strategy/knights-demo: add missing libcrypt compat dependency (diff)
downloadgentoo-40c751e9ebb33ae439d7513bc8ac7fbd72da6202.tar.gz
gentoo-40c751e9ebb33ae439d7513bc8ac7fbd72da6202.tar.bz2
gentoo-40c751e9ebb33ae439d7513bc8ac7fbd72da6202.zip
games-server/crossfire-server: add missing libcrypt, zlib dependencies, EAPI 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-server')
-rw-r--r--games-server/crossfire-server/crossfire-server-1.71.0-r2.ebuild (renamed from games-server/crossfire-server/crossfire-server-1.71.0-r1.ebuild)20
1 files changed, 14 insertions, 6 deletions
diff --git a/games-server/crossfire-server/crossfire-server-1.71.0-r1.ebuild b/games-server/crossfire-server/crossfire-server-1.71.0-r2.ebuild
index 3012afe88c9b..addefb17ecb4 100644
--- a/games-server/crossfire-server/crossfire-server-1.71.0-r1.ebuild
+++ b/games-server/crossfire-server/crossfire-server-1.71.0-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
MY_P="${P/-server/}"
DESCRIPTION="Server for the crossfire clients"
@@ -18,6 +18,8 @@ RESTRICT="test"
RDEPEND="
net-misc/curl
+ sys-libs/zlib
+ virtual/libcrypt:=
X? (
x11-libs/libXaw
media-libs/libpng:0=
@@ -27,8 +29,11 @@ DEPEND="${RDEPEND}"
src_prepare() {
default
- rm -f "${WORKDIR}"/maps/Info/combine.pl # bug #236205
- ln -s "${WORKDIR}/arch" "${S}/lib" || die
+
+ # bug #236205
+ rm -f "${WORKDIR}"/maps/Info/combine.pl || die
+ ln -s "${WORKDIR}"/arch "${S}"/lib || die
+
eapply "${FILESDIR}"/${P}-format.patch
}
@@ -44,8 +49,11 @@ src_compile() {
src_install() {
default
+
keepdir /var/lib/crossfire/{account,datafiles,maps,players,template-maps,unique-items}
+
insinto /usr/share/crossfire
- doins -r "${WORKDIR}/maps"
- find "${D}" -name '*.la' -delete || die
+ doins -r "${WORKDIR}"/maps
+
+ find "${ED}" -name '*.la' -delete || die
}