summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/textmaze
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/textmaze')
-rw-r--r--games-puzzle/textmaze/Manifest1
-rw-r--r--games-puzzle/textmaze/metadata.xml5
-rw-r--r--games-puzzle/textmaze/textmaze-1.2.ebuild32
3 files changed, 38 insertions, 0 deletions
diff --git a/games-puzzle/textmaze/Manifest b/games-puzzle/textmaze/Manifest
new file mode 100644
index 000000000000..76a87cfbe575
--- /dev/null
+++ b/games-puzzle/textmaze/Manifest
@@ -0,0 +1 @@
+DIST textmaze_v1.2.tar.gz 15827 SHA256 8dbd57584a57855bf052a47d366402cbd6257a546a5ae8e1166bdd91d0a6c0ad SHA512 f6a2733049ea461f15b40eec4a414356dbfe252d859d132278d9ea8a4efcdc6753a28817529b429bad662a2042f2f7cd5cb1f2383d9ddbf773c76b80ea2af7d9 WHIRLPOOL 697b12ca5d710c35b02efba0a6764c75b259c97470695e1dca1aa6ca6a26d52e67281e4124be22f27ea27ff0ae6ede6aab44f9933d33b14b42ac8ed596b88131
diff --git a/games-puzzle/textmaze/metadata.xml b/games-puzzle/textmaze/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/textmaze/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/textmaze/textmaze-1.2.ebuild b/games-puzzle/textmaze/textmaze-1.2.ebuild
new file mode 100644
index 000000000000..11063d9d01d0
--- /dev/null
+++ b/games-puzzle/textmaze/textmaze-1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+MY_P=${PN}_v${PV}
+DESCRIPTION="An ncurses-based maze solving game written in Perl"
+HOMEPAGE="http://robobunny.com/projects/textmaze/html/"
+SRC_URI="http://www.robobunny.com/projects/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-perl/Curses"
+
+S=${WORKDIR}/TextMaze
+
+src_prepare() {
+ sed -i \
+ -e "s#/usr/local/bin/perl#/usr/bin/perl#" \
+ textmaze || die
+}
+
+src_install() {
+ dogamesbin textmaze
+ dodoc CHANGES README
+ prepgamesdirs
+}