summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-05-25 23:38:31 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-05-25 23:38:42 +0100
commit0e0022cf7c98344343eb04454f8309aacff18b9b (patch)
tree886aa529311157577ebbc65943b11139efd6b9fe /games-emulation/dolphin
parentdev-libs/icu: Drop 64.1 (diff)
downloadgentoo-0e0022cf7c98344343eb04454f8309aacff18b9b.tar.gz
gentoo-0e0022cf7c98344343eb04454f8309aacff18b9b.tar.bz2
gentoo-0e0022cf7c98344343eb04454f8309aacff18b9b.zip
games-emulation/dolphin: fix libsoundtouch build, bug #686752
Reported-and-fixed-by: Sławomir Nizio Closes: https://bugs.gentoo.org/686752 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'games-emulation/dolphin')
-rw-r--r--games-emulation/dolphin/dolphin-5.0.ebuild3
-rw-r--r--games-emulation/dolphin/files/dolphin-5.0-soundtouch-exceptions.patch19
2 files changed, 21 insertions, 1 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0.ebuild b/games-emulation/dolphin/dolphin-5.0.ebuild
index 491d92991bef..871b1246ade5 100644
--- a/games-emulation/dolphin/dolphin-5.0.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -75,6 +75,7 @@ PATCHES=(
"${FILESDIR}"/${P}-CHAR_WIDTH-collision.patch
"${FILESDIR}"/${P}-xgetbv.patch
"${FILESDIR}"/${P}-no-pie.patch
+ "${FILESDIR}"/${P}-soundtouch-exceptions.patch
)
src_prepare() {
diff --git a/games-emulation/dolphin/files/dolphin-5.0-soundtouch-exceptions.patch b/games-emulation/dolphin/files/dolphin-5.0-soundtouch-exceptions.patch
new file mode 100644
index 000000000000..ffd07cf0697f
--- /dev/null
+++ b/games-emulation/dolphin/files/dolphin-5.0-soundtouch-exceptions.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/686752
+
+Description: Fix FTBFS with SoundTouch 2.1.2
+ Explicitly disable exceptions in SoundTouch headers because Dolphin
+ is compiled with -fno-exceptions.
+Author: James Cowgill <jcowgill@debian.org>
+Bug-Debian: https://bugs.debian.org/917671
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/Source/Core/AudioCommon/OpenALStream.h
++++ b/Source/Core/AudioCommon/OpenALStream.h
+@@ -32,6 +32,7 @@
+ #define BOOL SoundTouch_BOOL
+ #endif
+
++#define ST_NO_EXCEPTION_HANDLING
+ #include <soundtouch/SoundTouch.h>
+ #include <soundtouch/STTypes.h>
+