summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/blockrage
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/blockrage')
-rw-r--r--games-arcade/blockrage/Manifest1
-rw-r--r--games-arcade/blockrage/blockrage-0.2.3.ebuild27
-rw-r--r--games-arcade/blockrage/files/blockrage-0.2.3-config.patch30
-rw-r--r--games-arcade/blockrage/metadata.xml11
4 files changed, 69 insertions, 0 deletions
diff --git a/games-arcade/blockrage/Manifest b/games-arcade/blockrage/Manifest
new file mode 100644
index 000000000000..29a1ccd326f5
--- /dev/null
+++ b/games-arcade/blockrage/Manifest
@@ -0,0 +1 @@
+DIST blockrage-0.2.3.tar.gz 75620 SHA256 f9722e519fb74be2ecb9377fd2470c94382088a67df33acea215fd0a5a0b4cb6 SHA512 20ad63cb75f6f3afe482b54c5dc0487615ed9ac9a43fa3819b1da43f343c8dde6c3eb817b46b586bbfdca6ad9c9e9cb3c220f5ab536397e407250daf9fd61aa2 WHIRLPOOL 897bb7ea402ca0b79cf1246bc157853575664f22219518d905418bf838e47c31531e64a508028e3e22319e49a4cd2534482abe8affeaa4caf38875e2510a7366
diff --git a/games-arcade/blockrage/blockrage-0.2.3.ebuild b/games-arcade/blockrage/blockrage-0.2.3.ebuild
new file mode 100644
index 000000000000..abe431660f4f
--- /dev/null
+++ b/games-arcade/blockrage/blockrage-0.2.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="Falling-blocks arcade game with a 2-player hotseat mode"
+HOMEPAGE="http://blockrage.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl"
+RDEPEND="${DEPEND}"
+
+# Removing error due to wrong detection of cross-compile mode
+PATCHES=( "${FILESDIR}/${P}"-config.patch )
+DOCS=( ChangeLog KNOWN_BUGS README TODO )
+
+src_install() {
+ default
+ prepgamesdirs
+}
diff --git a/games-arcade/blockrage/files/blockrage-0.2.3-config.patch b/games-arcade/blockrage/files/blockrage-0.2.3-config.patch
new file mode 100644
index 000000000000..dc1875fc28e8
--- /dev/null
+++ b/games-arcade/blockrage/files/blockrage-0.2.3-config.patch
@@ -0,0 +1,30 @@
+--- configure
++++ configure
+@@ -40,7 +40,7 @@
+ SOUND_OPT=
+
+ MYCC=gcc
+-MYCFLAGS='-s -O2 -Wall `sdl-config --cflags`'" $SOUND_OPT -DSYSCONFDIR=\\\"\${sysconfdir}/\${progname}\\\""
++MYCFLAGS='-Wall `sdl-config --cflags`'" $SOUND_OPT -DSYSCONFDIR=\\\"\${sysconfdir}/\${progname}\\\""
+
+ if test -z "$CC" ; then
+ CC="$MYCC";
+@@ -75,7 +75,6 @@
+ --build=*) build_alias="$cfg_optarg";;
+ --host=*) if test ."$build_alias" != ."$cfg_optarg" ; then
+ printf "configure: cross-compiling not supported\n" >&2
+- exit 1
+ fi;;
+
+ --bindir=*) bindir="$cfg_optarg";;
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -1,7 +1,7 @@
+ OBJS = main.o gfxout.o gfxlib.o menus.o keyboard.o bg.o sound.o global.o timer.o
+
+ $(progname)$(XSUF): $(OBJS)
+- gcc -s -o $(progname)$(XSUF) $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) -o $(progname)$(XSUF) $(OBJS) $(LIBS) $(LDFLAGS)
+
+ bg.o: bg.c bg.h global.h main.h
+ gfxlib.o: gfxlib.c gfxlib.h global.h gfxout.h
diff --git a/games-arcade/blockrage/metadata.xml b/games-arcade/blockrage/metadata.xml
new file mode 100644
index 000000000000..9f40ff536fad
--- /dev/null
+++ b/games-arcade/blockrage/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+An arcade game with addictive gameplay and a 2-player hotseat mode.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">blockrage</remote-id>
+ </upstream>
+</pkgmetadata>