summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-06 21:59:56 +0000
committerSam James <sam@gentoo.org>2023-02-06 21:59:56 +0000
commita9e380dae81591f4dac0ac8d658b54e7e3ae79db (patch)
treee240e9cef62f32fe3e96688dc3601b917c86833a /games-arcade/berusky
parentapp-admin/perl-cleaner: Stabilize 2.30-r1 x86, #890473 (diff)
downloadgentoo-a9e380dae81591f4dac0ac8d658b54e7e3ae79db.tar.gz
gentoo-a9e380dae81591f4dac0ac8d658b54e7e3ae79db.tar.bz2
gentoo-a9e380dae81591f4dac0ac8d658b54e7e3ae79db.zip
games-arcade/berusky: fix build w/ gcc 12
Closes: https://bugs.gentoo.org/890361 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade/berusky')
-rw-r--r--games-arcade/berusky/berusky-1.7.1-r2.ebuild3
-rw-r--r--games-arcade/berusky/files/berusky-1.7.1-missing-includes.patch22
2 files changed, 24 insertions, 1 deletions
diff --git a/games-arcade/berusky/berusky-1.7.1-r2.ebuild b/games-arcade/berusky/berusky-1.7.1-r2.ebuild
index 65f429dfe17f..f50ada36626b 100644
--- a/games-arcade/berusky/berusky-1.7.1-r2.ebuild
+++ b/games-arcade/berusky/berusky-1.7.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,6 +26,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PN}-1.7.1-r2-gentoo.patch
+ "${FILESDIR}"/${PN}-1.7.1-missing-includes.patch
)
src_prepare() {
diff --git a/games-arcade/berusky/files/berusky-1.7.1-missing-includes.patch b/games-arcade/berusky/files/berusky-1.7.1-missing-includes.patch
new file mode 100644
index 000000000000..a44d142b7307
--- /dev/null
+++ b/games-arcade/berusky/files/berusky-1.7.1-missing-includes.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/890361
+--- a/src/level_game.cpp
++++ b/src/level_game.cpp
+@@ -27,6 +27,8 @@
+
+ #include "portability.h"
+
++#include <cassert>
++#include <cstddef>
+ #ifdef LINUX
+ #include <endian.h>
+ #endif // LINUX
+--- a/src/level_game.h
++++ b/src/level_game.h
+@@ -28,6 +28,7 @@
+ #ifndef __LEVEL_GAME_H__
+ #define __LEVEL_GAME_H__
+
++#include <cassert>
+ #include <time.h>
+ #include "stack.h"
+