summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-08-01 04:10:27 -0500
committerMichał Górny <mgorny@gentoo.org>2018-08-15 12:32:51 +0200
commit41c34906e393f7b34e45f650911f6ab810e60b11 (patch)
treeffd31caa53898337160c297cd60dac5d4a76ee64 /games-action/bomberclone
parentgames-action/barrage: add missing gnome2-utils (diff)
downloadgentoo-41c34906e393f7b34e45f650911f6ab810e60b11.tar.gz
gentoo-41c34906e393f7b34e45f650911f6ab810e60b11.tar.bz2
gentoo-41c34906e393f7b34e45f650911f6ab810e60b11.zip
games-action/bomberclone: eutils->{desktop,vcs-clean}, prefix awareness
Only has eutils for the implicit desktop and vcs-clean inheritance. desktop is used for doicon and make_desktop_entry. vcs-clean is used for ecvs_clean. Add ${EPREFIX} to the econf --datadir for prefix support. Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'games-action/bomberclone')
-rw-r--r--games-action/bomberclone/bomberclone-0.11.8-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/games-action/bomberclone/bomberclone-0.11.8-r1.ebuild b/games-action/bomberclone/bomberclone-0.11.8-r1.ebuild
index 31eb3fe53e87..08185dddd02d 100644
--- a/games-action/bomberclone/bomberclone-0.11.8-r1.ebuild
+++ b/games-action/bomberclone/bomberclone-0.11.8-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils autotools
+inherit autotools desktop vcs-clean
DESCRIPTION="BomberMan clone with network game support"
HOMEPAGE="https://www.bomberclone.de/"
@@ -39,7 +39,7 @@ src_prepare() {
src_configure() {
econf \
$(use_with X x) \
- --datadir=/usr/share
+ --datadir="${EPREFIX}"/usr/share
sed -i \
-e "/PACKAGE_DATA_DIR/ s:/usr/games/share/games/:/usr/share:" \
config.h || die
@@ -52,7 +52,7 @@ src_install() {
insinto /usr/share/${PN}
doins -r data/{gfx,maps,player,tileset,music}
- find "${D}" -name "Makefile*" -exec rm -f '{}' +
+ find "${D}" -name "Makefile*" -exec rm -f '{}' + || die
doicon data/pixmaps/bomberclone.png
make_desktop_entry bomberclone Bomberclone