summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-27 20:43:11 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-08 06:40:21 +0100
commit2fd092b4457fae45cf155a1a0e2cad00ca112851 (patch)
treeeea35f695d510488e945c98e816ac0dabd4bebf9 /eclass
parentdistutils-r1.eclass: Limit DISTUTILS_EXT logic to compile & test (diff)
downloadgentoo-2fd092b4457fae45cf155a1a0e2cad00ca112851.tar.gz
gentoo-2fd092b4457fae45cf155a1a0e2cad00ca112851.tar.bz2
gentoo-2fd092b4457fae45cf155a1a0e2cad00ca112851.zip
distutils-r1.eclass: Move filter-lto into DISTUTILS_EXT block
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils-r1.eclass12
1 files changed, 6 insertions, 6 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 60554944a5a0..ee1dcef24ff6 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1824,17 +1824,17 @@ distutils-r1_run_phase() {
# bug fixes from Cython (this works only when setup.py is using
# cythonize() but it's better than nothing)
local -x CYTHON_FORCE_REGEN=1
+
+ # Rust extensions are incompatible with C/C++ LTO compiler
+ # see e.g. https://bugs.gentoo.org/910220
+ if has cargo ${INHERITED}; then
+ filter-lto
+ fi
fi
# silence warnings when pydevd is loaded on Python 3.11+
local -x PYDEVD_DISABLE_FILE_VALIDATION=1
- # Rust extensions are incompatible with C/C++ LTO compiler
- # see e.g. https://bugs.gentoo.org/910220
- if has cargo ${INHERITED}; then
- filter-lto
- fi
-
# How to build Python modules in different worlds...
local ldopts
case "${CHOST}" in