summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-08-21 15:49:05 +0100
committerMarek Szuba <marecki@gentoo.org>2023-08-21 15:56:28 +0100
commit05c9a466f89d642be6dea54fce59b5b60167e9e5 (patch)
tree9dfd68ccc3df6fb4b0ffcdd2077b3b1226b8527d /dev-vcs/pre-commit
parentapp-backup/borgbackup: add myself as a maintainer (diff)
downloadgentoo-05c9a466f89d642be6dea54fce59b5b60167e9e5.tar.gz
gentoo-05c9a466f89d642be6dea54fce59b5b60167e9e5.tar.bz2
gentoo-05c9a466f89d642be6dea54fce59b5b60167e9e5.zip
dev-vcs/pre-commit: drop 3.3.2
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs/pre-commit')
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.3.2.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index c1591275d338..41bca9891ba4 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,3 +1,2 @@
DIST pre-commit-3.0.4.gh.tar.gz 264952 BLAKE2B 3c45da675d5a1a1fc115db0ef7186c1ec1e5a6d6d9353c5a53dba85a14de2c94bafe0ef9e8d0b04bae55ded81890d726997e695c95889719096205e1b212a237 SHA512 d51aca29b50f67ae42aa70d849939e6af96ff64c6fb214cddbc5a35cacebb8a54a4911110d0615a1a499516fcc2a06bb47d7e11da84ef636c3fcfdc8d2cbe343
-DIST pre-commit-3.3.2.gh.tar.gz 267100 BLAKE2B 5692baacb40482bdafb6ee9c912d98a248396f85b4f31303cb3f5f5aee0cfe68b1cdc2a6ab5ca82166632eb0f984acbad0a9ad2077a33f057e414433496da7f0 SHA512 9b0928cadb4530789f6dd87ea07c320eb76bec9501b46887929918f9dc5dc39773ead90536cb85cb317140682c2a4cee0dc7bcbc040759e76d504023cb5e40fd
DIST pre-commit-3.3.3.gh.tar.gz 267281 BLAKE2B dbe3b90dd3808d24084ede3e9bd76ddc5b070d43bd70b3fa813f8e8e95875a178b86632208463c50a3d68868f2dd9d888e00e7bf3aeba3f3b78c7cd39b514270 SHA512 d126bead7ffa2c72213a894c82bc45d0bce8b508cf7190e7b7d56c667b5d3ebff80eedf7ecb4bb1e01923ef9a43878b73356fda866614d8cbcc8f241ee9e01f7
diff --git a/dev-vcs/pre-commit/pre-commit-3.3.2.ebuild b/dev-vcs/pre-commit/pre-commit-3.3.2.ebuild
deleted file mode 100644
index 85138095ce63..000000000000
--- a/dev-vcs/pre-commit/pre-commit-3.3.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
- ')"
-# coreutils requirement: see Bug #885559
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
- sys-apps/coreutils[-multicall]
-)"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.1.1-tests_git_file_transport.patch
-)
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
-# and while some of them do include "skip if not found" logic, most of them do not.
-# The latter consistently fail with
-# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
-# including with the sandbox disabled.
-EPYTEST_DESELECT=(
- tests/languages/
- tests/repository_test.py
- tests/main_test.py::test_all_cmds
- tests/main_test.py::test_hook_stage_migration
- tests/main_test.py::test_try_repo
-)
-
-distutils_enable_tests pytest