summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2021-12-18 16:40:42 +0100
committerCédric Krier <cedk@gentoo.org>2021-12-18 16:41:06 +0100
commit23a6f9e69e4c356f05e563ed849efb6311eb7675 (patch)
treedcf0dd87f5a48f46f05c82fa82eba2c595586bfc /dev-vcs/mercurial
parentdev-libs/c-blosc: Remove old (diff)
downloadgentoo-23a6f9e69e4c356f05e563ed849efb6311eb7675.tar.gz
gentoo-23a6f9e69e4c356f05e563ed849efb6311eb7675.tar.bz2
gentoo-23a6f9e69e4c356f05e563ed849efb6311eb7675.zip
dev-vcs/mercurial: remove unsupported tests on big-endian
Closes: https://bugs.gentoo.org/815121 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Cédric Krier <cedk@gentoo.org>
Diffstat (limited to 'dev-vcs/mercurial')
-rw-r--r--dev-vcs/mercurial/mercurial-5.8.1.ebuild9
-rw-r--r--dev-vcs/mercurial/mercurial-5.9.3.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/dev-vcs/mercurial/mercurial-5.8.1.ebuild b/dev-vcs/mercurial/mercurial-5.8.1.ebuild
index 40001869a2f6..bed3532e284f 100644
--- a/dev-vcs/mercurial/mercurial-5.8.1.ebuild
+++ b/dev-vcs/mercurial/mercurial-5.8.1.ebuild
@@ -127,7 +127,7 @@ zstd-safe-2.0.5+zstd.1.4.5
zstd-sys-1.4.17+zstd.1.4.5
"
-inherit bash-completion-r1 cargo elisp-common distutils-r1 flag-o-matic multiprocessing
+inherit bash-completion-r1 cargo elisp-common distutils-r1 flag-o-matic multiprocessing toolchain-funcs
DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="https://www.mercurial-scm.org/"
@@ -269,6 +269,13 @@ src_test() {
rm -f test-convert-tla* # GNU Arch tla
rm -f test-largefiles* # tends to time out
rm -f test-https* # requires to support tls1.0
+ if [[ $(tc-endian) == "big" ]]; then
+ # tests no working on big-endian
+ # https://bz.mercurial-scm.org/show_bug.cgi?id=6607
+ rm -f test-clone-uncompressed.t
+ rm -f test-generaldelta.t
+ rm -f test-persistent-nodemap.t
+ fi
if [[ ${EUID} -eq 0 ]]; then
einfo "Removing tests which require user privileges to succeed"
rm -f test-convert*
diff --git a/dev-vcs/mercurial/mercurial-5.9.3.ebuild b/dev-vcs/mercurial/mercurial-5.9.3.ebuild
index bcba2835a327..3f1017f98f7f 100644
--- a/dev-vcs/mercurial/mercurial-5.9.3.ebuild
+++ b/dev-vcs/mercurial/mercurial-5.9.3.ebuild
@@ -123,7 +123,7 @@ CRATES="
zstd-sys-1.4.17+zstd.1.4.5
"
-inherit bash-completion-r1 cargo elisp-common distutils-r1 flag-o-matic multiprocessing
+inherit bash-completion-r1 cargo elisp-common distutils-r1 flag-o-matic multiprocessing toolchain-funcs
DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="https://www.mercurial-scm.org/"
@@ -261,6 +261,13 @@ src_test() {
rm -f test-largefiles* # tends to time out
rm -f test-https* # requires to support tls1.0
rm -rf test-removeemptydirs* # requires access to access parent directories
+ if [[ $(tc-endian) == "big" ]]; then
+ # tests no working on big-endian
+ # https://bz.mercurial-scm.org/show_bug.cgi?id=6607
+ rm -f test-clone-uncompressed.t
+ rm -f test-generaldelta.t
+ rm -f test-persistent-nodemap.t
+ fi
if [[ ${EUID} -eq 0 ]]; then
einfo "Removing tests which require user privileges to succeed"
rm -f test-convert*