summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-27 21:49:45 +0100
committerSam James <sam@gentoo.org>2023-10-27 21:51:21 +0100
commitae9de819e53391f17f0288318232e1ef6e7cb0fd (patch)
treee9f8e34865088729d8d7857f301323c1da621673 /dev-util
parentsys-libs/glibc: disable aarch64 mathvec for headers-only (diff)
downloadgentoo-ae9de819e53391f17f0288318232e1ef6e7cb0fd.tar.gz
gentoo-ae9de819e53391f17f0288318232e1ef6e7cb0fd.tar.bz2
gentoo-ae9de819e53391f17f0288318232e1ef6e7cb0fd.zip
dev-util/libabigail: add 2.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/libabigail/Manifest2
-rw-r--r--dev-util/libabigail/libabigail-2.4.ebuild120
-rw-r--r--dev-util/libabigail/libabigail-9999.ebuild4
3 files changed, 124 insertions, 2 deletions
diff --git a/dev-util/libabigail/Manifest b/dev-util/libabigail/Manifest
index 24cc3eaed38d..fb1527c78e1c 100644
--- a/dev-util/libabigail/Manifest
+++ b/dev-util/libabigail/Manifest
@@ -2,3 +2,5 @@ DIST libabigail-2.2-docs.tar.xz 46776 BLAKE2B 469981ea9879b202bcfd68dfa1d71c2547
DIST libabigail-2.2.tar.xz 351078692 BLAKE2B fc03b1653fbe94213713e710c358133a2abd51cac46c8d4b5d797715b16e3d9923ddd99f9a2f85352599b6b5628f52e505f0ec2bca6dc3ea118826bbe69ff42b SHA512 c512c4a497ea6bb88283feae6c31cf5fe347c260cf1670fe65296bf158d3a2aa449ca518a4f2780e814ffbe6970c7856d2ab91e15499638db78bc52d67d794ce
DIST libabigail-2.3-docs.tar.xz 48016 BLAKE2B 5649dec61017cada11fefcb40d71ecf438d3e2753c32cf424514ece2d5b737415f220e7a36b0edc597c3155a954c994256da7745e22318ae63dfb58d8d3bd72b SHA512 8ead43911fcb7cb3c3bc63ef7dea911ff72a4249845e1d79e28a730fb05216088713905daad31b228b5fc2b6f50b492321b68989be50a427f59425006a4ccc6f
DIST libabigail-2.3.tar.xz 381350984 BLAKE2B 1a580cdc0f60fbf6edbf701e65531fb2b7254232a24edc23600aee49de87eea1c07c4ab93d55c1bce17ce7e0be6e074c7aab83ed6e3aff9076a844c224e52c74 SHA512 fdf0df51e2c262c723c11bef58cd0b89b27e67be196edeb33444fc06e7e61d3c2c227f59cb961aea6fc0c9b7f6f04e08b787a1cbbeb3d5507b968b8ae7630527
+DIST libabigail-2.4-docs.tar.xz 50320 BLAKE2B 6e3cc1a8ffc42d0a1307ed57576ec31254d4831ad785b868504ea67310d9a25633403a87b545ee6bcbedb164c7f2ac7fdef307a15a28520daebc505c7da852eb SHA512 48ede7c3b6bab8b26dfdbe3683f4ec6dd9ef0f4626e8bd7b4bc0242795bcad0f7638ee4dee21a65aa3c8f178514aa42223e67ff5a2804c8167db0bcc5bd4a105
+DIST libabigail-2.4.tar.xz 357840964 BLAKE2B c3d1c23c598fc8754405df10fcd1cfded6fe80e6949ae9d15ee28e99aad571477b331ceac2aeaa5a93f47da77de7ca41a692902b741e3a4aea1d72a7043d4a91 SHA512 f9b51f8710c75b911da10c1e93e0b6b6fa575f99e8f37a5f51e93a8e6b79c9ad1541e531730b410385053d6565f807300f7910dca48cbd3e991d111198781d95
diff --git a/dev-util/libabigail/libabigail-2.4.ebuild b/dev-util/libabigail/libabigail-2.4.ebuild
new file mode 100644
index 000000000000..885005cc2531
--- /dev/null
+++ b/dev-util/libabigail/libabigail-2.4.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Generate using https://github.com/thesamesam/sam-gentoo-scripts/blob/main/niche/generate-libabigail-docs
+# Set to 1 if prebuilt, 0 if not
+# (the construct below is to allow overriding from env for script)
+: ${LIBABIGAIL_DOCS_PREBUILT:=1}
+
+LIBABIGAIL_DOCS_PREBUILT_DEV=sam
+LIBABIGAIL_DOCS_VERSION="${PV}"
+# Default to generating docs (inc. man pages) if no prebuilt; overridden later
+# bug #830088
+LIBABIGAIL_DOCS_USEFLAG="+doc"
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools bash-completion-r1 python-any-r1 out-of-source
+
+DESCRIPTION="Suite of tools for checking ABI differences between ELF objects"
+HOMEPAGE="https://sourceware.org/libabigail/"
+if [[ ${PV} == 9999 ]] ; then
+ LIBABIGAIL_DOCS_PREBUILT=0
+ EGIT_REPO_URI="https://sourceware.org/git/libabigail.git"
+ inherit git-r3
+else
+ SRC_URI="https://mirrors.kernel.org/sourceware/libabigail/${P}.tar.xz"
+ if [[ ${LIBABIGAIL_DOCS_PREBUILT} == 1 ]] ; then
+ SRC_URI+=" !doc? ( https://dev.gentoo.org/~${LIBABIGAIL_DOCS_PREBUILT_DEV}/distfiles/${CATEGORY}/${PN}/${PN}-${LIBABIGAIL_DOCS_VERSION}-docs.tar.xz )"
+ LIBABIGAIL_DOCS_USEFLAG="doc"
+ fi
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="Apache-2.0-with-LLVM-exceptions"
+SLOT="0/3"
+IUSE="btf debug ${LIBABIGAIL_DOCS_USEFLAG} test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/elfutils
+ dev-libs/libxml2:2
+ btf? ( dev-libs/libbpf:= )
+ elibc_musl? ( sys-libs/fts-standalone )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-python/sphinx
+ sys-apps/texinfo
+ )
+ test? ( ${PYTHON_DEPS} )
+"
+
+src_prepare() {
+ default
+ # need to run our autotools, due to ltmain.sh including Redhat calls:
+ # cannot read spec file '/usr/lib/rpm/redhat/redhat-hardened-ld': No such file or directory
+ eautoreconf
+}
+
+my_src_configure() {
+ local myeconfargs=(
+ --disable-deb
+ --disable-fedabipkgdiff
+ --disable-rpm
+ --disable-rpm415
+ --disable-ctf
+ --disable-debug-ct-propagation
+ # Don't try to run Valgrind on tests.
+ --disable-valgrind
+ --enable-bash-completion
+ --enable-python3
+ $(use_enable debug assert)
+ $(use_enable btf)
+ $(use_enable doc apidoc)
+ $(use_enable doc manual)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+my_src_compile() {
+ default
+ use doc && emake doc
+}
+
+my_src_install() {
+ emake DESTDIR="${D}" install
+
+ # If USE=doc, there'll be newly generated docs which we install instead.
+ if ! use doc && [[ ${LIBABIGAIL_DOCS_PREBUILT} == 1 ]] ; then
+ doinfo "${WORKDIR}"/${PN}-${LIBABIGAIL_DOCS_VERSION}-docs/texinfo/*.info
+ doman "${WORKDIR}"/${PN}-${LIBABIGAIL_DOCS_VERSION}-docs/man/*.[0-8]
+ elif use doc; then
+ doman doc/manuals/man/*
+ doinfo doc/manuals/texinfo/abigail.info
+
+ dodoc -r doc/manuals/html
+
+ docinto html/api
+ dodoc -r doc/api/html/.
+ fi
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ local file
+ for file in abicompat abidiff abidw abilint abinilint abipkgdiff abisym fedabipkgdiff ; do
+ dobashcomp bash-completion/${file}
+ done
+
+ # No static archives
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-util/libabigail/libabigail-9999.ebuild b/dev-util/libabigail/libabigail-9999.ebuild
index 9dca18088bcc..885005cc2531 100644
--- a/dev-util/libabigail/libabigail-9999.ebuild
+++ b/dev-util/libabigail/libabigail-9999.ebuild
@@ -14,7 +14,7 @@ LIBABIGAIL_DOCS_VERSION="${PV}"
# bug #830088
LIBABIGAIL_DOCS_USEFLAG="+doc"
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit autotools bash-completion-r1 python-any-r1 out-of-source
@@ -35,7 +35,7 @@ else
fi
LICENSE="Apache-2.0-with-LLVM-exceptions"
-SLOT="0/2"
+SLOT="0/3"
IUSE="btf debug ${LIBABIGAIL_DOCS_USEFLAG} test"
RESTRICT="!test? ( test )"