summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-23 11:34:25 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-23 11:34:25 +0200
commitb98f5ed0bea9d4ae9596f8d9cb381b5d585134bc (patch)
tree74170c08074397bd668fc43cd81b5d4ec8cc4607 /dev-util/spec-cleaner/spec-cleaner-9999.ebuild
parentdev-util/bumpversion: Remove last-rited pkg (diff)
downloadgentoo-b98f5ed0bea9d4ae9596f8d9cb381b5d585134bc.tar.gz
gentoo-b98f5ed0bea9d4ae9596f8d9cb381b5d585134bc.tar.bz2
gentoo-b98f5ed0bea9d4ae9596f8d9cb381b5d585134bc.zip
dev-util/spec-cleaner: Remove last-rited pkg
Closes: https://bugs.gentoo.org/718296 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/spec-cleaner/spec-cleaner-9999.ebuild')
-rw-r--r--dev-util/spec-cleaner/spec-cleaner-9999.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-util/spec-cleaner/spec-cleaner-9999.ebuild b/dev-util/spec-cleaner/spec-cleaner-9999.ebuild
deleted file mode 100644
index 1a01126a84cc..000000000000
--- a/dev-util/spec-cleaner/spec-cleaner-9999.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-EGIT_REPO_URI="https://github.com/openSUSE/spec-cleaner.git"
-inherit distutils-r1
-[[ ${PV} == 9999 ]] && inherit git-r3
-
-DESCRIPTION="SUSE spec file cleaner and formatter"
-HOMEPAGE="https://github.com/openSUSE/spec-cleaner"
-[[ ${PV} != 9999 ]] && SRC_URI="https://github.com/openSUSE/${PN}/archive/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-[[ ${PV} != 9999 ]] &&
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${PYTHON_DEPS}
- >=app-arch/rpm-4.11.0.1
-"
-
-PATCHES=(
- # pytest-runner is only needed in test scenario
- "${FILESDIR}/${PN}-1.0.6-pytest-runner.patch"
-)
-
-[[ ${PV} != 9999 ]] && S="${WORKDIR}/${PN}-${P}"
-
-src_prepare() {
- # we have libexec
- sed -i \
- -e 's:lib/obs:libexec/obs:g' \
- setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- esetup.py test
-}