summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2020-03-02 23:24:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-16 22:25:43 +0100
commitf731f2b51e2ab8415bb3abf75b043bc1c1b91819 (patch)
tree26e7e3cc334e9b7869e9269834562a190f061537 /dev-util/mdds
parentdev-util/mdds: Bump to 1.5.0 (diff)
downloadgentoo-f731f2b51e2ab8415bb3abf75b043bc1c1b91819.tar.gz
gentoo-f731f2b51e2ab8415bb3abf75b043bc1c1b91819.tar.bz2
gentoo-f731f2b51e2ab8415bb3abf75b043bc1c1b91819.zip
dev-util/mdds: Update live ebuild
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/mdds')
-rw-r--r--dev-util/mdds/mdds-9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
index 2709004f0637..37717bcfe9a5 100644
--- a/dev-util/mdds/mdds-9999.ebuild
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
inherit git-r3
else
@@ -17,7 +17,8 @@ HOMEPAGE="https://gitlab.com/mdds/mdds"
LICENSE="MIT"
SLOT="1/${PV%.*}"
-IUSE="doc valgrind"
+IUSE="doc valgrind test"
+RESTRICT="!test? ( test )"
BDEPEND="
doc? (
@@ -29,22 +30,24 @@ BDEPEND="
DEPEND="dev-libs/boost:="
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-1.4.3-buildsystem.patch" )
+PATCHES=( "${FILESDIR}/${PN}-1.5.0-buildsystem.patch" )
src_prepare() {
default
+
eautoreconf
}
src_configure() {
- econf \
- $(use_enable doc docs) \
+ local myeconfargs=(
+ $(use_enable doc docs)
$(use_enable valgrind memory_tests)
+ )
+ econf "${myeconfargs[@]}"
}
-src_compile() { :; }
-
src_test() {
tc-export CXX
+
default
}