summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-30 10:18:57 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-30 10:48:02 +0200
commit5a1b1a83989bf2b3e5894b91dbe5398b439f999f (patch)
treea8189087a76c850df4d6ee63d2c2775dfa5d48ed /dev-util/kcov
parentdev-util/kcov: enable py3.11, py3.12 (diff)
downloadgentoo-5a1b1a83989bf2b3e5894b91dbe5398b439f999f.tar.gz
gentoo-5a1b1a83989bf2b3e5894b91dbe5398b439f999f.tar.bz2
gentoo-5a1b1a83989bf2b3e5894b91dbe5398b439f999f.zip
dev-util/kcov: Sync live ebuild
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-util/kcov')
-rw-r--r--dev-util/kcov/kcov-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-util/kcov/kcov-9999.ebuild b/dev-util/kcov/kcov-9999.ebuild
index 201ab239e41c..acf228ac0b9d 100644
--- a/dev-util/kcov/kcov-9999.ebuild
+++ b/dev-util/kcov/kcov-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake python-any-r1
DESCRIPTION="Kcov is a code coverage tester for compiled languages, Python and Bash"
HOMEPAGE="https://github.com/SimonKagstrom/kcov"
@@ -24,6 +25,12 @@ RDEPEND="dev-libs/elfutils
sys-libs/zlib
binutils? ( sys-libs/binutils-libs:= )"
DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-binutils-2.39.patch
+ "${FILESDIR}"/${P}-gcc-13.patch
+)
src_configure() {
local mycmakeargs=(