summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-07-30 21:55:18 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-07-30 21:55:18 -0500
commit3043529b6b748cf7b474e55e9e013f0b03f64ec4 (patch)
tree5f576ea10bc243eca4fe7d717bd802773f7aba0f /dev-util/gitlab-runner
parentdev-util/gitlab-runner: add 17.2.0 (diff)
downloadgentoo-3043529b6b748cf7b474e55e9e013f0b03f64ec4.tar.gz
gentoo-3043529b6b748cf7b474e55e9e013f0b03f64ec4.tar.bz2
gentoo-3043529b6b748cf7b474e55e9e013f0b03f64ec4.zip
dev-util/gitlab-runner: drop 16.11.2
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-16.11.2.ebuild62
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index f96e2814870b..6e205b8ce2a1 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -1,5 +1,3 @@
-DIST gitlab-runner-16.11.2-deps.tar.xz 85890592 BLAKE2B f7316c038e5036799e02d1cd42bf39fbc25a02223b022d6cbb988d1072b4cdac3d652aad068531ebdbf46e16349b35b152d56801920aea05cc1bde0af820952d SHA512 bf01403946883ef3d204064bbf776c3372442e56b1404ee26c092f8e031770786d13ea796a11c41782257f6492ae2c78a8792dc8be6bae9f5be211b904e783b4
-DIST gitlab-runner-16.11.2.tar.bz2 1378922 BLAKE2B 43e896f0680e834d63ce92a1103796fe651067fec62662a186da307e5279f3d9449a6b04867c09a8bf72a3e4c431727c3145dfba5d405c24b881598cdeaebe3f SHA512 c05e5f398fdd5f80fa13dffc21e820d9ce4d34e3e1186c71c818c9e9da7ffec8c79559d5e875b691e824ca0ee0d7598b0166cf7a68e27136b10bf86195fb701e
DIST gitlab-runner-17.0.1-deps.tar.xz 85885404 BLAKE2B 5145aa9e3bd95c5de993ab846a7d2db3e8e24188c088ffd2788d7e4e055eabe86915cb330590ace6ad5238c90590ac4567faf176947a21c506ef2fa1a8adce35 SHA512 45beaeacd4b734cbabd1991d68827b8f3bb7aaa5e002fb7bb35689b231cc0a2348beca3472ebabb00593fcafc8ae42b7b370e268b7d4c1c2e7d757e7bffa3504
DIST gitlab-runner-17.0.1.tar.bz2 1371456 BLAKE2B 99516e587ac4801e84308062e04d587f48d735c4645dbc8f7d7a9f55e995758dad7972f708a5d14b2e8e3114f4f1794d7ed544ecb8d7477995c16235857e0366 SHA512 f3af26c252263f101a1e97f61c4df3a99c3d83361bea4be86c06fcff487a8f8829af2b3fd03c8c25341298300f575a35bd82b64580640f8cd8418528a9a67066
DIST gitlab-runner-17.1.0-deps.tar.xz 86656984 BLAKE2B 7766a3764d8ba17e3943f16a63e2af9705a23080bed23f30c813f07c4ce71057665682d6221790ff767848fefe258ffb796866d1a4e2a693faea1edd55945a30 SHA512 d2b8df673f8ab6a0380bbf3604d71fd963894f5bf55ba91c8755f827654b8b1fd394401c2654a78684dab022ac6f356befbfd862282a1a503422553ce8bd76fc
diff --git a/dev-util/gitlab-runner/gitlab-runner-16.11.2.ebuild b/dev-util/gitlab-runner/gitlab-runner-16.11.2.ebuild
deleted file mode 100644
index 0ac7bf610b23..000000000000
--- a/dev-util/gitlab-runner/gitlab-runner-16.11.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd tmpfiles
-
-# make sure this gets updated for every bump
-GIT_COMMIT=1d04b67a
-
-DESCRIPTION="The official GitLab Runner, written in Go"
-HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
-SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 ~riscv"
-
-COMMON_DEPEND="acct-group/gitlab-runner
- acct-user/gitlab-runner"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-BDEPEND="dev-go/gox"
-
-DOCS=( docs CHANGELOG.md README.md config.toml.example )
-
-S="${WORKDIR}/${PN}-v${PV}"
-
-src_compile() {
- emake \
- BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
- GOX="${EPREFIX}/usr/bin/gox" \
- REVISION=${GIT_COMMIT} \
- VERSION=${PV} \
- runner-bin-host
-}
-
-src_test() {
- CI=0 ego test
-}
-
-src_install() {
- dobin out/binaries/gitlab-runner
- einstalldocs
-
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- systemd_dounit "${FILESDIR}/${PN}.service"
- newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
- keepdir /{etc,var/log}/${PN}
- fperms 0700 /{etc,var/log}/gitlab-runner
- fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
-}
-
-pkg_postinst() {
- tmpfiles_process gitlab-runner.conf
- [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
- elog
- elog "To use the runner, you need to register it with this command:"
- elog "# gitlab-runner register"
- elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
-}