summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-06-26 09:55:23 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-06-26 09:55:23 -0500
commit1c63fb7db32bab18790db15922d8b8d48210c54c (patch)
tree890e8d42c6481fd5f13ba79eb160591b2d34eec2 /dev-util/gitlab-runner
parentdev-util/gitlab-runner: add 17.1.0 (diff)
downloadgentoo-1c63fb7db32bab18790db15922d8b8d48210c54c.tar.gz
gentoo-1c63fb7db32bab18790db15922d8b8d48210c54c.tar.bz2
gentoo-1c63fb7db32bab18790db15922d8b8d48210c54c.zip
dev-util/gitlab-runner: drop 16.10.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-16.10.0.ebuild62
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index ca7e6b029117..29b7531d9392 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -1,5 +1,3 @@
-DIST gitlab-runner-16.10.0-deps.tar.xz 87356404 BLAKE2B 87616f6544efcfddf854ccf8892ab955f44d11fa6f7ec3a5d0c2d32f165adf985011997e701b325e7eedfb4532547dbb94e08df3118d591550d511c09a9cc957 SHA512 6f800f4f965767898a21c9e4c7b0fc5f07ae089910f98ae96189b2501434f3de8a51ac6326e4df2234f3524bce4b15e4b05b183473988e717d2067d022e6c67f
-DIST gitlab-runner-16.10.0.tar.bz2 1373754 BLAKE2B ca0d39a4c04cc37afc48d9346266d075da6f4c3f62891d871a6d21e357de62067ea34e1dbffa34a410e2fb0656742eb46bcd3e555a56a20d6429b2c590e96fda SHA512 445cc39bd4d4b5ecf092fb4850b4224c0312b5b6a5aafdfb44ead5c590cf6ff38d759f765b1a97bd3beae73b5dd733daba53a33d3cb5d1f1346af28d39509b7c
DIST gitlab-runner-16.11.1-deps.tar.xz 86847148 BLAKE2B 68520b6ae8a0250ffe134e1bd19360e142c51ec012df026212f80f8c4f23e8bce633451606502cf0af6762489564ff71c4fab5aafc04513695f161d929fa3ec2 SHA512 695f23266ebd82ed6bcf22da6eb41fd69404d929dbc55cc0e2d1f8e01f476d5343d88b9f07198447af2030b48db085ae382e7f627eb685e1c19f99ddaf55b483
DIST gitlab-runner-16.11.1.tar.bz2 1377748 BLAKE2B c2dd939c30f1eccedaaa8d941abceea258a445d4b6c4518231cdc7e1ebc34d61912c5f1fd9e338d482a6ced547e8174dde6938b746334b215c50ee83ba1b8781 SHA512 80ac885a6d04f97c85222e87b4a3aabfa949caa060eae538d873c6b5172cb3de8234f36a9db3daaa5df132de1ac18d6f5c6a5a267cd4448dd87e98bdd393cf25
DIST gitlab-runner-17.0.0-deps.tar.xz 86841028 BLAKE2B c7952e6028869264ed6d728043074ef5318230db18ea06a5ab740262693f22bd3111c5ad99ca2da2ca57079e3389b5a87a9994635f98fe6670f87df97e158956 SHA512 1c705bacc8eb896b23dee06ed4258c22cb0ba96073725761f2e138d4687efab4a1866e76203c1f7694c8d71995e18ad96d7da333fe88c24aa3454ac5caf4dc63
diff --git a/dev-util/gitlab-runner/gitlab-runner-16.10.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-16.10.0.ebuild
deleted file mode 100644
index cf259193f257..000000000000
--- a/dev-util/gitlab-runner/gitlab-runner-16.10.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd tmpfiles
-
-# make sure this gets updated for every bump
-GIT_COMMIT=81ab07f6
-
-DESCRIPTION="The official GitLab Runner, written in Go"
-HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
-SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 ~riscv"
-
-COMMON_DEPEND="acct-group/gitlab-runner
- acct-user/gitlab-runner"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-BDEPEND="dev-go/gox"
-
-DOCS=( docs CHANGELOG.md README.md config.toml.example )
-
-S="${WORKDIR}/${PN}-v${PV}"
-
-src_compile() {
- emake \
- BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
- GOX="${EPREFIX}/usr/bin/gox" \
- REVISION=${GIT_COMMIT} \
- VERSION=${PV} \
- runner-bin-host
-}
-
-src_test() {
- CI=0 ego test
-}
-
-src_install() {
- dobin out/binaries/gitlab-runner
- einstalldocs
-
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- systemd_dounit "${FILESDIR}/${PN}.service"
- newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
- keepdir /{etc,var/log}/${PN}
- fperms 0700 /{etc,var/log}/gitlab-runner
- fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
-}
-
-pkg_postinst() {
- tmpfiles_process gitlab-runner.conf
- [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
- elog
- elog "To use the runner, you need to register it with this command:"
- elog "# gitlab-runner register"
- elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
-}