summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-06-03 15:30:18 +0200
committerJeroen Roovers <jer@gentoo.org>2018-06-03 15:33:01 +0200
commitb3620f5a2deaa7709595f8ffaf73f7e61a8a4462 (patch)
tree1743ed96419571c1d846dfd659b12018aafdd44e /dev-util/debootstrap
parentx11-misc/kapow: Old. (diff)
downloadgentoo-b3620f5a2deaa7709595f8ffaf73f7e61a8a4462.tar.gz
gentoo-b3620f5a2deaa7709595f8ffaf73f7e61a8a4462.tar.bz2
gentoo-b3620f5a2deaa7709595f8ffaf73f7e61a8a4462.zip
dev-util/debootstrap: Version 1.0.100.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-util/debootstrap')
-rw-r--r--dev-util/debootstrap/Manifest1
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.100.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/debootstrap/Manifest b/dev-util/debootstrap/Manifest
index e0a9b67576d7..f42c61ef1723 100644
--- a/dev-util/debootstrap/Manifest
+++ b/dev-util/debootstrap/Manifest
@@ -1,3 +1,4 @@
+DIST debootstrap_1.0.100.tar.gz 72269 BLAKE2B 76cb0268d3401463bd4ba72f0bab6b2d854b762df092c7fd6320b15d0de17d6a53ca1beb32df0cbe6beffe0a85909611a8b5ff8b9356fbf61501360cd2eeec98 SHA512 36bdf55207d73f9b5c259b1d9c19c36918778ca35478bf654a97d82d5e98fb6293fbf68adfa2e0a113e0d53ec48f19173232587fb1f727068b2516e9e51436d3
DIST debootstrap_1.0.89.tar.gz 69020 BLAKE2B 9175d0936b6c9a28a29ee1b24bd835c41aaf807bc24a029201aaa45d07789206ee06e38b0a70c1e507ab448a3ec9c0fded2838bfb868334270b5159b34cbe9eb SHA512 3f230ce3eff6359353d106c806ce395861fb47fc1416eb0b498af7ce12a45ce7572b18284633d6d4d07b73a4a203e03bc205df3eae0db6f637237d25d0a69b1a
DIST debootstrap_1.0.98.tar.gz 71819 BLAKE2B 4ac11484540407b8a4ebd1dac42ba99bc1d079989bcbe9b5a69ebb97f621e6beae34a2057726517a69a111087dbbe788e205b73a65a5330578aba3f63db9e34d SHA512 4ab6c6599f09c0d0d851d991cbe780ab6a74df4dd46df02d40e1e03682ea57680a69044a1524c75392e1e726aa538b4fca4fb26e42a140ac4cc00f86c0af29cd
DIST debootstrap_1.0.99.tar.gz 71865 BLAKE2B 073c3c42133e2fa459cfc3e6a1737e8ceeb2f28986c139734c77a40fb57db293bf664493f6e10f4c1cfac83297b61e9e8fe1da267cc848a1e459fdd6af2ef157 SHA512 1eae4be2b50e98c1c867701affee8b4c63a54418af789bca78ff411c4c97a6284139850d71c118fddd6c62df9223f9ff960a21d45ccf8bdadc9bf0b11eb315fe
diff --git a/dev-util/debootstrap/debootstrap-1.0.100.ebuild b/dev-util/debootstrap/debootstrap-1.0.100.ebuild
new file mode 100644
index 000000000000..93ffd5d2d1aa
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.100.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}