summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-07-03 14:23:02 +0000
committerSam James <sam@gentoo.org>2023-07-26 04:00:06 +0100
commit48d0eac751aee8fafd4a01ee513ed7db42c0ca34 (patch)
tree7c78e97cc1202139f39a3f4295b4266c09b3cf2e /dev-util/codespell
parentdev-libs/stfl: Use correct flags from pkg-config for ncurses widechar (diff)
downloadgentoo-48d0eac751aee8fafd4a01ee513ed7db42c0ca34.tar.gz
gentoo-48d0eac751aee8fafd4a01ee513ed7db42c0ca34.tar.bz2
gentoo-48d0eac751aee8fafd4a01ee513ed7db42c0ca34.zip
dev-util/codespell: Add 2.2.5
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/31729 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/codespell')
-rw-r--r--dev-util/codespell/Manifest1
-rw-r--r--dev-util/codespell/codespell-2.2.5.ebuild23
-rw-r--r--dev-util/codespell/files/codespell-2.2.5-drop-coverage.patch13
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/codespell/Manifest b/dev-util/codespell/Manifest
index 66e734ab8f74..a7e8b39bac0f 100644
--- a/dev-util/codespell/Manifest
+++ b/dev-util/codespell/Manifest
@@ -1 +1,2 @@
DIST codespell-2.2.4.tar.gz 241664 BLAKE2B 5f40003fdb840b926615b6eed74df90055b2ee47c534321289c3ed895c47cd2672909b152a53640899cc21960c1b3aa80c41eb344d9e23cea8fd13e998c71af6 SHA512 efbc62a3dd49781565f6d901aa9b08fc1106adf2c516365dd8d3684846e23b23bfda1e65c6530edf0de9462ccafd9d835bd541a8f0e1de14163c723ce041052d
+DIST codespell-2.2.5.tar.gz 242918 BLAKE2B 18b4ff620edb54950ba2779ec610f15597d0aef5e4dded3ed2055ce7769e16d70dbac9cf990b2bdb6c216f8f6204e4a7790fe011ec53057553ca6981b4d8c851 SHA512 173eb13695ceccb4bb081907fc8d703e91922ec7adddc150aa2db1629353edff464c2318f2abaf78e8c96ab28f08e510897912f5bd48d69a6c50e025d470b53f
diff --git a/dev-util/codespell/codespell-2.2.5.ebuild b/dev-util/codespell/codespell-2.2.5.ebuild
new file mode 100644
index 000000000000..ce8d9368fb0e
--- /dev/null
+++ b/dev-util/codespell/codespell-2.2.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Check text files for common misspellings"
+HOMEPAGE="https://pypi.org/project/codespell https://github.com/codespell-project/codespell"
+
+# Code licensed under GPL-2, dictionary licensed under CC-BY-SA-3.0
+LICENSE="GPL-2 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="test? ( dev-python/chardet[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.5-drop-coverage.patch )
+
+distutils_enable_tests pytest
diff --git a/dev-util/codespell/files/codespell-2.2.5-drop-coverage.patch b/dev-util/codespell/files/codespell-2.2.5-drop-coverage.patch
new file mode 100644
index 000000000000..498f419acca1
--- /dev/null
+++ b/dev-util/codespell/files/codespell-2.2.5-drop-coverage.patch
@@ -0,0 +1,13 @@
+diff -urEbw codespell-2.2.5/pyproject.toml codespell-2.2.5.new/pyproject.toml
+--- codespell-2.2.5/pyproject.toml 2023-06-14 19:28:54.000000000 +0200
++++ codespell-2.2.5.new/pyproject.toml 2023-07-03 16:19:11.225597607 +0200
+@@ -99,7 +99,7 @@
+ strict = true
+
+ [tool.pytest.ini_options]
+-addopts = "--cov=codespell_lib -rs --cov-report= --tb=short --junit-xml=junit-results.xml"
++addopts = "-rs --cov-report= --tb=short --junit-xml=junit-results.xml"
+
+ [tool.ruff]
+ extend-ignore = [
+