summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-05-15 18:57:21 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-05-15 19:07:12 -0700
commit30e15e5008438c36161855ff0a51ad1c637a50e6 (patch)
tree0cfaced5e77197467bf4514919d7f63497188a32 /dev-util/buildbot/buildbot-9999.ebuild
parentdev-util/buildbot-worker: Version bump, adds py3.5 capability (diff)
downloadgentoo-30e15e5008438c36161855ff0a51ad1c637a50e6.tar.gz
gentoo-30e15e5008438c36161855ff0a51ad1c637a50e6.tar.bz2
gentoo-30e15e5008438c36161855ff0a51ad1c637a50e6.zip
dev-util/buildbot: Version bump, adds py3.5 capability
Clean older versions. Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30
Diffstat (limited to 'dev-util/buildbot/buildbot-9999.ebuild')
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild44
1 files changed, 13 insertions, 31 deletions
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index cd94d2d541ad..834f434691d9 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="5"
PYTHON_REQ_USE="sqlite"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
EGIT_REPO_URI="https://github.com/buildbot/${PN}.git"
@@ -14,7 +14,7 @@ MY_PV="${PV/_p/p}"
MY_P="${PN}-${MY_PV}"
DESCRIPTION="BuildBot build automation system"
-HOMEPAGE="http://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot"
[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
@@ -25,42 +25,30 @@ else
KEYWORDS="~amd64"
fi
-IUSE="crypt doc examples irc mail manhole test"
+IUSE="crypt doc examples irc test"
-RDEPEND=">=dev-python/jinja-2.1[${PYTHON_USEDEP}]
- || (
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-14.0.1[${PYTHON_USEDEP}]
- )
+RDEPEND="
+ >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/twisted-16.0.0[${PYTHON_USEDEP},crypt?]' python2_7 )
+ $(python_gen_cond_dep '>=dev-python/twisted-17.1.0[${PYTHON_USEDEP},crypt?]' python3_5 python3_6 )
>=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-0.8[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-migrate-0.9[${PYTHON_USEDEP}]
crypt? (
- >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
dev-python/idna[${PYTHON_USEDEP}]
dev-python/service_identity[${PYTHON_USEDEP}]
)
irc? (
dev-python/txrequests[${PYTHON_USEDEP}]
- || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-words-14.0.1[${PYTHON_USEDEP}]
- )
- )
- mail? (
- || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-mail-14.0.1[${PYTHON_USEDEP}]
- )
- )
- manhole? (
- || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-conch-14.0.1[${PYTHON_USEDEP}]
- )
)
dev-python/future[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
>=dev-python/txaio-2.2.2[${PYTHON_USEDEP}]
dev-python/pyjwt[${PYTHON_USEDEP}]
- "
+ dev-python/distro[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-4.1.1[${PYTHON_USEDEP}]
+"
DEPEND="${RDEPEND}
>=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
doc? (
@@ -69,19 +57,13 @@ DEPEND="${RDEPEND}
dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
dev-python/pyenchant[${PYTHON_USEDEP}]
>=dev-python/docutils-0.8[${PYTHON_USEDEP}]
+ <dev-python/docutils-0.13.0[${PYTHON_USEDEP}]
dev-python/sphinx-jinja[${PYTHON_USEDEP}]
+ dev-python/ramlfications[${PYTHON_USEDEP}]
)
test? (
>=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- || (
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- (
- >=dev-python/twisted-mail-14.0.1[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-14.0.1[${PYTHON_USEDEP}]
- >=dev-python/twisted-words-14.0.1[${PYTHON_USEDEP}]
- )
- )
dev-python/moto[${PYTHON_USEDEP}]
dev-python/boto3[${PYTHON_USEDEP}]
dev-python/ramlfications[${PYTHON_USEDEP}]