summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2022-05-29 16:32:44 -0700
committerBrian Dolbec <dolsen@gentoo.org>2022-05-29 17:11:16 -0700
commit8a578c9388af58d32ca825edb229015d111679d1 (patch)
tree1eafff7c7aa53dbe16d1b6835c4d16710560116a /dev-util/buildbot-pkg
parentsys-apps/systemd: update HOMEPAGE (diff)
downloadgentoo-8a578c9388af58d32ca825edb229015d111679d1.tar.gz
gentoo-8a578c9388af58d32ca825edb229015d111679d1.tar.bz2
gentoo-8a578c9388af58d32ca825edb229015d111679d1.zip
dev-util/buildbot-pkg: Bump to 3.5.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-pkg')
-rw-r--r--dev-util/buildbot-pkg/Manifest1
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-3.5.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/Manifest b/dev-util/buildbot-pkg/Manifest
index 8f2cc075560c..b24d38f62009 100644
--- a/dev-util/buildbot-pkg/Manifest
+++ b/dev-util/buildbot-pkg/Manifest
@@ -1 +1,2 @@
DIST buildbot-pkg-3.4.0.tar.gz 4809 BLAKE2B 6d3e549e7b44b5ad95bb7520ef8765828da587e3940a9f352ede63346b3303127313fe4b71338ff65ef9ab2c0ac6258793bd9ef664153a0b45b0b6d7d2d92943 SHA512 ca1ef22fb6113bfe0106360ba1eacb167a8335ba15f94a0635bc4d00f999818704f8cfebd7889b6b3df5e1ca7ab79b96f4656e481d6b1f25f5fb7404af0d7ff6
+DIST buildbot-pkg-3.5.0.tar.gz 4806 BLAKE2B 41e217bc029bb8dbdb0f95218640d57d9f9ecabfbc0310118898042bbb543d9d4e5ba88075e934a9be9b1653e2a3d3d1e159547b832f9cde08c262713a817968 SHA512 08b3ec93dfbef87d90cfd4b7b1402003df785ceff8c43bf0320de79ff0efcb74f4cb4f0ec736e0d7231b54a82761d40df66e21540f1756fe74f68bb550850b1c
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-3.5.0.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-3.5.0.ebuild
new file mode 100644
index 000000000000..edf7eaf4cf37
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-3.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-pkg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
+
+# No real integration tests for this pkg.
+# all tests are related to making releases and final checks for distribution
+RESTRICT="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -e "/version/s/=.*$/=\"${MY_PV}\",/" -i setup.py || die
+ distutils-r1_src_prepare
+}