summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-11-07 21:58:07 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-11-07 21:58:35 +0100
commita5474661a2d448e8ae23309679fcd752d43519d8 (patch)
treedc84950b4fa98b3982c0f332b4f2233561bd658b /dev-util/bcc
parentdev-util/bcc: Correctly append "old" prefix to old tools' names (diff)
downloadgentoo-a5474661a2d448e8ae23309679fcd752d43519d8.tar.gz
gentoo-a5474661a2d448e8ae23309679fcd752d43519d8.tar.bz2
gentoo-a5474661a2d448e8ae23309679fcd752d43519d8.zip
dev-util/bcc: Cleanup deps, bump max llvm version
Havent't encountered any issues with llvm-13 so let's enable it in the package. Also cleanup libbpf deps, any version above 0.5.0 should be good (although currently there is no newer version than 0.5.0 released) Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-util/bcc')
-rw-r--r--dev-util/bcc/bcc-0.22.0-r1.ebuild23
1 files changed, 8 insertions, 15 deletions
diff --git a/dev-util/bcc/bcc-0.22.0-r1.ebuild b/dev-util/bcc/bcc-0.22.0-r1.ebuild
index 36f7b33c57d7..bca83ca19de0 100644
--- a/dev-util/bcc/bcc-0.22.0-r1.ebuild
+++ b/dev-util/bcc/bcc-0.22.0-r1.ebuild
@@ -10,7 +10,6 @@ inherit cmake linux-info llvm lua-single python-r1
DESCRIPTION="Tools for BPF-based Linux IO analysis, networking, monitoring, and more"
HOMEPAGE="https://iovisor.github.io/bcc/"
-
SRC_URI="https://github.com/iovisor/bcc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
@@ -19,19 +18,17 @@ KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="+lua test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
lua? ( ${LUA_REQUIRED_USE} )"
+# tests need root access
+RESTRICT="test"
RDEPEND="
- || (
- ~dev-libs/libbpf-0.5.0
- ~dev-libs/libbpf-9999
- )
- dev-libs/libbpf:=[static-libs(-)]
- >=sys-kernel/linux-headers-5.13
>=dev-libs/elfutils-0.166:=
- <=sys-devel/clang-13:=
- <=sys-devel/llvm-13:=[llvm_targets_BPF(+)]
- lua? ( ${LUA_DEPS} )
+ >=dev-libs/libbpf-0.5.0:=[static-libs(-)]
+ >=sys-kernel/linux-headers-5.13
+ <=sys-devel/clang-14:=
+ <=sys-devel/llvm-14:=[llvm_targets_BPF(+)]
${PYTHON_DEPS}
+ lua? ( ${LUA_DEPS} )
"
DEPEND="${RDEPEND}
test? (
@@ -44,7 +41,6 @@ DEPEND="${RDEPEND}
)
"
BDEPEND="
- dev-util/cmake
virtual/pkgconfig
"
@@ -53,9 +49,6 @@ PATCHES=(
"${FILESDIR}/bcc-0.14.0-cmakelists.patch"
)
-# tests need root access
-RESTRICT="test"
-
pkg_pretend() {
local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~NET_CLS_BPF ~NET_ACT_BPF
~HAVE_EBPF_JIT ~BPF_EVENTS ~DEBUG_INFO ~FUNCTION_TRACER ~KALLSYMS_ALL
@@ -65,7 +58,7 @@ pkg_pretend() {
}
pkg_setup() {
- LLVM_MAX_SLOT=12 llvm_pkg_setup
+ LLVM_MAX_SLOT=13 llvm_pkg_setup
python_setup
}