summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-06-28 06:20:34 +0200
committerHans de Graaff <graaff@gentoo.org>2024-06-28 06:31:29 +0200
commitdcb5faccc3fdf693184f7cb77abf91e1fdee677b (patch)
tree84ce368c6ea78dcabc2b48925a4b960e84cbe1b5 /dev-ruby/tilt
parentdev-python/rustworkx: Bump to 0.15.0 (diff)
downloadgentoo-dcb5faccc3fdf693184f7cb77abf91e1fdee677b.tar.gz
gentoo-dcb5faccc3fdf693184f7cb77abf91e1fdee677b.tar.bz2
gentoo-dcb5faccc3fdf693184f7cb77abf91e1fdee677b.zip
dev-ruby/tilt: add 2.4.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/Manifest1
-rw-r--r--dev-ruby/tilt/tilt-2.4.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index 77c0ab3704ee..db2ed5a53c72 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1,2 +1,3 @@
DIST tilt-2.2.0.tar.gz 57826 BLAKE2B 10729ac9cb2e2d0b2292a6fdacc0d705179d719d7f4bbdb11075e0eeaeb82933daec22063d3448ea2ada6e50f37b2b66303854707f50162efd11a6151ded45df SHA512 135a32402512fda71952dc2534b02a291d749dbdcb9e17f52c7fa6ecfe3bd7e894f28f3d3d4a595daa63ffbe90cca106347aa916541292558a26d8122fcd7c90
DIST tilt-2.3.0.tar.gz 57454 BLAKE2B 2c3c934e73c015be850951c67731b2f1640fb340ab1807c72c654363c2ab3aca939b8452327cd54e2c1964add81176cec0dfd2639901284476f0dd13d42a2ccf SHA512 3438c196c2e0936f2c3551fe3786d71b1336118352b97c95d3504b900082ce4248bbaf715f3f812eb7fe6e959767c75e316bf6cd5b659c216bbfd630dbf678bc
+DIST tilt-2.4.0.tar.gz 58520 BLAKE2B fe07437d62de1db062625c1ead3a81ed34bba0c7169181d44216b5f42b1b742b2c7900c079affbae13831d1370044827384da4302b6e92a01f151b36b37f3772 SHA512 3053479b9f258e01620db5f4af02247179df39f18baae2b5b83eac23046effafcd6f47575432158bb752e3019dcb0aadb67ca11236a12ea01e2211354b7418d1
diff --git a/dev-ruby/tilt/tilt-2.4.0.ebuild b/dev-ruby/tilt/tilt-2.4.0.ebuild
new file mode 100644
index 000000000000..b76fb674cff9
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+RUBY_FAKEGEM_GEMSPEC="tilt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/jeremyevans/tilt"
+SRC_URI="https://github.com/jeremyevans/tilt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to facilitate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/erubi
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+ sed -e '7irequire "uri"' -i test/test_helper.rb || die
+}