summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-22 11:06:13 +0000
committerSam James <sam@gentoo.org>2023-03-23 06:51:30 +0000
commitb051a9681a982940ed209333598dae1becb6e889 (patch)
tree7f80b95d374181acdedea8f036c86dbfa07deb07 /dev-ruby/ruby-progressbar
parentdev-ruby/fuubar: update upstream metadata (diff)
downloadgentoo-b051a9681a982940ed209333598dae1becb6e889.tar.gz
gentoo-b051a9681a982940ed209333598dae1becb6e889.tar.bz2
gentoo-b051a9681a982940ed209333598dae1becb6e889.zip
dev-ruby/ruby-progressbar: add 1.13.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/Manifest1
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/Manifest b/dev-ruby/ruby-progressbar/Manifest
index c9d7f83bc40c..382b50679200 100644
--- a/dev-ruby/ruby-progressbar/Manifest
+++ b/dev-ruby/ruby-progressbar/Manifest
@@ -1 +1,2 @@
DIST ruby-progressbar-1.11.0.tar.gz 61341 BLAKE2B 558de9d15f6c3eafb0a9ef0b39db279727651c8f86234f3ffad1faac7e9ab7f6bdef6662fadb2132bf10d70bcac9412801a695e0bb3afa5879a48dd363920734 SHA512 5a5c8a6af410746ef601821ec171933d781d32bfb7cb5f67f9cf877824a399941c11be69bb74380941f2271f6f5139928599881441f88860a71f8b7f7b55d4b4
+DIST ruby-progressbar-1.13.0.tar.gz 67185 BLAKE2B 27ea25e4caeb70aefb2523a4f4399056bdb9973deb567fc80eb9daeab6193ecc3693c8364bb43fc94906e6b63a0db1ace6bbd9b00defa0e02177983371b54ad3 SHA512 64723422d6216f2640bc60c8068c8d0437fbc5f315343b13c3167130d868a0aa978f098554ace3ea71406688c0b3c0ed94296adc6b9229ea14df5dbcb56322a3
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild
new file mode 100644
index 000000000000..b77912c368ba
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-progressbar.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+SRC_URI="https://github.com/jfelchner/ruby-progressbar/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-progressbar-releases-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_bdepend "test? ( dev-ruby/rspectacular dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/warning_filter/ s:^:#:' \
+ spec/spec_helper.rb || die
+}