summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-02-11 06:43:06 +0100
committerHans de Graaff <graaff@gentoo.org>2019-02-11 06:43:06 +0100
commita6addec6a6d5a5bf498bc5eccbdf79a4282e69b7 (patch)
tree4d78dbfec86f6e62396760a2c551b948753fe075 /dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.3.2.ebuild
parentdev-ruby/slim: cleanup (diff)
downloadgentoo-a6addec6a6d5a5bf498bc5eccbdf79a4282e69b7.tar.gz
gentoo-a6addec6a6d5a5bf498bc5eccbdf79a4282e69b7.tar.bz2
gentoo-a6addec6a6d5a5bf498bc5eccbdf79a4282e69b7.zip
dev-ruby/ruby-gobject-introspection: add 3.3.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.3.2.ebuild')
-rw-r--r--dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.3.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.3.2.ebuild b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.3.2.ebuild
new file mode 100644
index 000000000000..a49fe1f9dc1a
--- /dev/null
+++ b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/gobject-introspection
+
+DESCRIPTION="Ruby GObjectIntrospection bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/gobject-introspection"
+RDEPEND+=" dev-libs/gobject-introspection"
+
+ruby_add_rdepend "~dev-ruby/ruby-glib2-${PV}"
+
+all_ruby_prepare() {
+ # Remove pregenerated Makefile since it will otherwise be shared by all targets.
+ rm -f Makefile Makefile.lib ext/gobject-introspection/Makefile || die
+
+ # Avoid native installer
+ sed -i -e '/native-package-installer/ s:^:#: ; /^\s*setup_homebrew_libffi/ s:^:#:' ../glib2/lib/mkmf-gnome2.rb || die
+
+ # Avoid unneeded dependency on test-unit-notify.
+ sed -i -e '/notify/ s:^:#:' test/gobject-introspection-test-utils.rb || die
+
+ # Avoid compilation of dependencies during test.
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}