summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rcairo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rcairo')
-rw-r--r--dev-ruby/rcairo/Manifest1
-rw-r--r--dev-ruby/rcairo/metadata.xml5
-rw-r--r--dev-ruby/rcairo/rcairo-1.14.1-r1.ebuild76
-rw-r--r--dev-ruby/rcairo/rcairo-1.14.1.ebuild76
4 files changed, 158 insertions, 0 deletions
diff --git a/dev-ruby/rcairo/Manifest b/dev-ruby/rcairo/Manifest
new file mode 100644
index 000000000000..5bfeed543172
--- /dev/null
+++ b/dev-ruby/rcairo/Manifest
@@ -0,0 +1 @@
+DIST cairo-1.14.1.gem 96768 SHA256 e93a7bc97687d2725b77f4651656f77a42a134e39129e05c853c6eac1929ae4d SHA512 08d045f5763ed61ff10fe7d5388532e4fd6be24411a9e5e1ea3cc17de48092cab0723cbf17208eb488fa3322114f4112182983a487516db291173644a0dee355 WHIRLPOOL cc0056366208c6b3f722042758a6a469b0ffe4dcb8a71fc17970773e4fad05208efd46d7b354feb71230ecedd839d719cbde1685f5c113288f7777bda58ff52c
diff --git a/dev-ruby/rcairo/metadata.xml b/dev-ruby/rcairo/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/rcairo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/rcairo/rcairo-1.14.1-r1.ebuild b/dev-ruby/rcairo/rcairo-1.14.1-r1.ebuild
new file mode 100644
index 000000000000..364f51e41487
--- /dev/null
+++ b/dev-ruby/rcairo/rcairo-1.14.1-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_NAME="cairo"
+
+# Documentation depends on files that are not distributed.
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="AUTHORS NEWS"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby bindings for cairo"
+HOMEPAGE="http://cairographics.org/rcairo/"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="|| ( Ruby GPL-2 )"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="${RDEPEND}
+ >=x11-libs/cairo-1.2.0[svg]"
+DEPEND="${DEPEND}
+ >=x11-libs/cairo-1.2.0[svg]"
+
+ruby_add_bdepend "
+ dev-ruby/pkg-config
+ dev-ruby/ruby-glib2
+ test? ( >=dev-ruby/test-unit-2.1.0-r1:2 )"
+
+all_ruby_prepare() {
+ # Avoid development dependency.
+ sed -i -e '/notify/ s:^:#:' test/cairo-test-utils.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/cairo extconf.rb || die "extconf failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/cairo
+
+ # again, try to make it more standard, to install it more easily.
+ cp ext/cairo/cairo$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ # don't rely on the Rakefile because it's a mess to load with
+ # their hierarchy, do it manually.
+ ${RUBY} -Ilib -r ./test/cairo-test-utils.rb \
+ -e 'gem "test-unit"; require "test/unit"; Dir.glob("test/**/test_*.rb") {|f| load f}' || die "tests failed"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ insinto $(ruby_get_hdrdir)
+ doins ext/cairo/rb_cairo.h
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/samples
+ doins -r samples/*
+}
diff --git a/dev-ruby/rcairo/rcairo-1.14.1.ebuild b/dev-ruby/rcairo/rcairo-1.14.1.ebuild
new file mode 100644
index 000000000000..0821812f22eb
--- /dev/null
+++ b/dev-ruby/rcairo/rcairo-1.14.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_NAME="cairo"
+
+# Documentation depends on files that are not distributed.
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="AUTHORS NEWS"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby bindings for cairo"
+HOMEPAGE="http://cairographics.org/rcairo/"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="|| ( Ruby GPL-2 )"
+KEYWORDS="amd64 ~ppc x86"
+
+RDEPEND="${RDEPEND}
+ >=x11-libs/cairo-1.2.0[svg]"
+DEPEND="${DEPEND}
+ >=x11-libs/cairo-1.2.0[svg]"
+
+ruby_add_bdepend "
+ dev-ruby/pkg-config
+ dev-ruby/ruby-glib2
+ test? ( >=dev-ruby/test-unit-2.1.0-r1:2 )"
+
+all_ruby_prepare() {
+ # Avoid development dependency.
+ sed -i -e '/notify/ s:^:#:' test/cairo-test-utils.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/cairo extconf.rb || die "extconf failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/cairo
+
+ # again, try to make it more standard, to install it more easily.
+ cp ext/cairo/cairo$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ # don't rely on the Rakefile because it's a mess to load with
+ # their hierarchy, do it manually.
+ ${RUBY} -Ilib -r ./test/cairo-test-utils.rb \
+ -e 'gem "test-unit"; require "test/unit"; Dir.glob("test/**/test_*.rb") {|f| load f}' || die "tests failed"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ insinto $(ruby_get_hdrdir)
+ doins ext/cairo/rb_cairo.h
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/samples
+ doins -r samples/*
+}