summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-07-18 15:48:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-07-18 15:51:50 -0500
commitcfa7d225553abdf993589d9d3506f393860f8325 (patch)
treee26a1cda091c77a400993c46f6c823512fc19e18 /dev-ruby/puppetdb-termini
parentapp-admin/puppet-agent: 5.5.4 bup (diff)
downloadgentoo-cfa7d225553abdf993589d9d3506f393860f8325.tar.gz
gentoo-cfa7d225553abdf993589d9d3506f393860f8325.tar.bz2
gentoo-cfa7d225553abdf993589d9d3506f393860f8325.zip
dev-ruby/puppetdb-termini: 5.2.4 bup
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-5.2.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index c6eb745cb57b..aeb154965256 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1 +1,2 @@
DIST puppetdb-termini_5.2.2-1xenial_all.deb 20540 BLAKE2B 2aa48a9de8e512d81fd2e38fff4664bf3ccc69d4fdc6558edf1838171dbc01f3e87186a84a3308c33955336ba3b7d0d70dee640da0cf145ed1624d2341f7614b SHA512 7ac62306b16af0ebd9423a66ac911d35ac11403f45b03d2efe0a4d7c2aec3572670abd0c8930bd3b141c8d4a3aaf1c0b849535e74361b0b1f273b93a6bd855e8
+DIST puppetdb-termini_5.2.4-1xenial_all.deb 20538 BLAKE2B aad000bc0e13e3c97f4428bca88653cbfd76db2e5499f2acad90afcff58847e1dbaec9bc9ae8ec30e21c9b5c8308061b7d51058f0a17e2936d6dfd05ccc650f4 SHA512 98e871a4867735a8ca677ee3fbb6ab5e8718e78623fe6d497a3c680e090b86a0cefc35ee318f6f5abb45ebfd02d9bf75a04f0f1fc48ba654443c5c4ca99f3180
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-5.2.4.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-5.2.4.ebuild
new file mode 100644
index 000000000000..ecc47a98cfa9
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-5.2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/xenial/puppet5/${PN:0:1}/${PN}/${PN}_${PV}-1xenial_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}