summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-29 07:52:58 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-29 07:52:58 +0100
commitf4aa3174bfcba744e797485cad88cbc47135fb45 (patch)
treefdf12f3ee49e39a84aaa00130e63dbd679986798 /dev-ruby/public_suffix
parentapp-admin/puppet: also backport ruby 2.3.6 fix to puppet 5.x (diff)
downloadgentoo-f4aa3174bfcba744e797485cad88cbc47135fb45.tar.gz
gentoo-f4aa3174bfcba744e797485cad88cbc47135fb45.tar.bz2
gentoo-f4aa3174bfcba744e797485cad88cbc47135fb45.zip
avoid need for bundler dependency
Closes: https://bugs.gentoo.org/645972 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/public_suffix')
-rw-r--r--dev-ruby/public_suffix/public_suffix-2.0.5.ebuild7
-rw-r--r--dev-ruby/public_suffix/public_suffix-3.0.1.ebuild5
2 files changed, 7 insertions, 5 deletions
diff --git a/dev-ruby/public_suffix/public_suffix-2.0.5.ebuild b/dev-ruby/public_suffix/public_suffix-2.0.5.ebuild
index c550eaee0332..ccf55cfb3cfb 100644
--- a/dev-ruby/public_suffix/public_suffix-2.0.5.ebuild
+++ b/dev-ruby/public_suffix/public_suffix-2.0.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+USE_RUBY="ruby22 ruby23 ruby24"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRAINSTALL="data"
@@ -22,6 +22,7 @@ ruby_add_bdepend "test? ( dev-ruby/mocha )"
all_ruby_prepare() {
sed -i -e '/rubocop/I s:^:#:' \
- -e '/yardoc/,/end/ s:^:#:' Rakefile || die
+ -e '/yardoc/,/end/ s:^:#:' \
+ -e '/bundler/ s:^:#:' Rakefile || die
sed -i -e '/reporters/I s:^:#:' test/test_helper.rb || die
}
diff --git a/dev-ruby/public_suffix/public_suffix-3.0.1.ebuild b/dev-ruby/public_suffix/public_suffix-3.0.1.ebuild
index 0994676f87e0..38e346e0bee5 100644
--- a/dev-ruby/public_suffix/public_suffix-3.0.1.ebuild
+++ b/dev-ruby/public_suffix/public_suffix-3.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,6 +24,7 @@ ruby_add_bdepend "test? ( dev-ruby/mocha )"
all_ruby_prepare() {
sed -i -e '/rubocop/I s:^:#:' \
- -e '/yardoc/,/CLOBBER.include/ s:^:#:' Rakefile || die
+ -e '/yardoc/,/CLOBBER.include/ s:^:#:' \
+ -e '/bundler/ s:^:#:' Rakefile || die
sed -i -e '/reporters/I s:^:#:' test/test_helper.rb || die
}