summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-11-04 07:04:14 +0100
committerHans de Graaff <graaff@gentoo.org>2016-11-04 07:06:55 +0100
commitf81b91f54ccf43bfe90ebab72c4c62741324471b (patch)
tree94f17e0a6597ac26776352fac11a188e1e31d745 /dev-ruby/posix-spawn/posix-spawn-0.3.12.ebuild
parentapp-emulation/rkt: version bump to 1.18.0 (diff)
downloadgentoo-f81b91f54ccf43bfe90ebab72c4c62741324471b.tar.gz
gentoo-f81b91f54ccf43bfe90ebab72c4c62741324471b.tar.bz2
gentoo-f81b91f54ccf43bfe90ebab72c4c62741324471b.zip
dev-ruby/posix-spawn: add 0.3.12
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/posix-spawn/posix-spawn-0.3.12.ebuild')
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.12.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.12.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.12.ebuild
new file mode 100644
index 000000000000..5e278fa96ed9
--- /dev/null
+++ b/dev-ruby/posix-spawn/posix-spawn-0.3.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+KEYWORDS="~amd64"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library that implements a subset of the Ruby 1.9 Process::spawn"
+HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each {|f| require f}' || die
+}