summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-13 08:12:56 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-13 08:12:56 +0100
commit56ff372d67201d680ccff44b8865e4442b0fde05 (patch)
treeca0d6c8b6d0c82c031b9f7310107cd00422e4fb0 /dev-ruby/pairing_heap
parentdev-ruby/gettext-setup: enable ruby33 (diff)
downloadgentoo-56ff372d67201d680ccff44b8865e4442b0fde05.tar.gz
gentoo-56ff372d67201d680ccff44b8865e4442b0fde05.tar.bz2
gentoo-56ff372d67201d680ccff44b8865e4442b0fde05.zip
dev-ruby/pairing_heap: add 3.1.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pairing_heap')
-rw-r--r--dev-ruby/pairing_heap/Manifest1
-rw-r--r--dev-ruby/pairing_heap/pairing_heap-3.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/pairing_heap/Manifest b/dev-ruby/pairing_heap/Manifest
index 52df2cec258c..21e6162b7005 100644
--- a/dev-ruby/pairing_heap/Manifest
+++ b/dev-ruby/pairing_heap/Manifest
@@ -1 +1,2 @@
DIST pairing_heap-3.0.1.tar.gz 16965 BLAKE2B 80200dd98676c8ee9258ef96d296a4169b56d104875368bb8401b0f7d53494e3bbff8cfc5a536bdb24d844893ebe6962af709614b399c8c56980ee578ec2740b SHA512 0d22ccd42275aec54ff6960094c7ef14ad487835ba23217882a649c66585fc6c21af8a2f27f7a0a410fba6daf157ffdae6b74f1fdd798903ac597851945dee41
+DIST pairing_heap-3.1.0.tar.gz 17034 BLAKE2B 45d093df803b02109b2f8c339ac2f138606c3f2edf6c0430acedec0691c938d9bc38ff6c822267c7bceaa0ff9537070411db1ffba2c9565aaa7427a39d9b242e SHA512 b41f11d31c92bc9946bafe9d2be9d13df2cc3b67d7266e6bc7efa1c28c4a7a1ad6f4809070ba874594beb3146cc07a928034d29fd4247f139039bf03cf0c4809
diff --git a/dev-ruby/pairing_heap/pairing_heap-3.1.0.ebuild b/dev-ruby/pairing_heap/pairing_heap-3.1.0.ebuild
new file mode 100644
index 000000000000..7bebc219b1bc
--- /dev/null
+++ b/dev-ruby/pairing_heap/pairing_heap-3.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="pairing_heap.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Performant priority queue with support for changing priority"
+HOMEPAGE="https://github.com/mhib/pairing_heap"
+SRC_URI="https://github.com/mhib/pairing_heap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+
+# We normally patch out simplecov but the test suite does not work
+# correctly without it.
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/simplecov )"
+
+all_ruby_prepare() {
+ sed -i -e '/require.*\(bundler\|standard\)/ s:^:#:' Rakefile || die
+
+ sed -e 's:_relative ": "./:' \
+ -e 's/__dir__/"."/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}