summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-06 08:16:44 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-06 08:48:30 +0200
commit7d8449092f04b67222a9c381892dd88dcc1907f9 (patch)
tree736469db48381a9a2b2ffbc9acdcc1686d3a21d0 /dev-ruby/oauth2
parentapp-admin/mcollective: add ruby27 (diff)
downloadgentoo-7d8449092f04b67222a9c381892dd88dcc1907f9.tar.gz
gentoo-7d8449092f04b67222a9c381892dd88dcc1907f9.tar.bz2
gentoo-7d8449092f04b67222a9c381892dd88dcc1907f9.zip
dev-ruby/oauth2: cleanup
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/Manifest1
-rw-r--r--dev-ruby/oauth2/oauth2-1.4.3.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
index 4d2978b3295b..1d61fe510aca 100644
--- a/dev-ruby/oauth2/Manifest
+++ b/dev-ruby/oauth2/Manifest
@@ -1,2 +1 @@
-DIST oauth2-1.4.3.tar.gz 28278 BLAKE2B 6d0055875073dca48e94a0449a5fff22b7be280c5b2f8e0b5b3234b3c8b079fde0671e211b0eb8d562bfc0cb437917adccb3f13c38450a8cd6a43f0f1a2373a5 SHA512 6ffdc7675ed301cd52e3320c01723fe2530a9dedc2b1fe534b42d01dacb7d4b017d79dbe0f9768f06ed8ace7ba596f9824a38d5509e82d09a3456f3a6b1fe453
DIST oauth2-1.4.4.tar.gz 28477 BLAKE2B 925008fcf4dd48da3b17c539713bf0f05f649d431ab1676293de625bef4165f31153271d48bbb0c6265c67d7bb6a3cbc7217ce155ba331b22a00d572a855a8ef SHA512 5398a25664e53d1942b0ecbe5d74ca9cc8f04a928c96073f40cfff207c4bf220634185320954a0d1f36944547fb48264855c9523318fbb79dd4a3779a7a46e79
diff --git a/dev-ruby/oauth2/oauth2-1.4.3.ebuild b/dev-ruby/oauth2/oauth2-1.4.3.ebuild
deleted file mode 100644
index f046e1a04dd0..000000000000
--- a/dev-ruby/oauth2/oauth2-1.4.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="oauth2.gemspec"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
-HOMEPAGE="https://github.com/intridea/oauth2"
-SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/faraday-0.8 <dev-ruby/faraday-2.0
- || ( dev-ruby/jwt:2 dev-ruby/jwt:0 )
- >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
- >=dev-ruby/multi_xml-0.5:0
- >=dev-ruby/rack-1.2:* <dev-ruby/rack-3:*"
-ruby_add_bdepend "test? ( dev-ruby/rspec:3 )"
-
-all_ruby_prepare() {
- sed -i -e '/simplecov/,/^ end/ s:^:#:' \
- -e '/silent/I s:^:#:' \
- -e '1irequire "uri"' spec/helper.rb || die
-
- sed -i -e '/yardstick/,/^end/ s:^:#:' \
- -e '/bundler/I s:^:#:' Rakefile || die
-
- # Avoid spec that is too fragile in relation to ENV
- sed -i -e '/outputs to $stdout when OAUTH_DEBUG=true/a skip "fragile ENV stubbing"' spec/oauth2/client_spec.rb || die
-
- sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- CI=true ${RUBY} -S rspec-3 spec || die
-}