summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-31 09:49:57 +0100
committerHans de Graaff <graaff@gentoo.org>2021-10-31 12:35:54 +0100
commit855f691949e5cd9c40aa75e932dd757b8151a8ec (patch)
treebe5ea014f4ee6b04a79e3879d19499fee69e4f8f /dev-ruby/itextomml/itextomml-1.6.1.ebuild
parentwww-plugins/passff-host: drop 1.2.1-r1 (diff)
downloadgentoo-855f691949e5cd9c40aa75e932dd757b8151a8ec.tar.gz
gentoo-855f691949e5cd9c40aa75e932dd757b8151a8ec.tar.bz2
gentoo-855f691949e5cd9c40aa75e932dd757b8151a8ec.zip
dev-ruby/itextomml: add 1.6.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/itextomml/itextomml-1.6.1.ebuild')
-rw-r--r--dev-ruby/itextomml/itextomml-1.6.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/itextomml/itextomml-1.6.1.ebuild b/dev-ruby/itextomml/itextomml-1.6.1.ebuild
new file mode 100644
index 000000000000..a6eb145fd8c5
--- /dev/null
+++ b/dev-ruby/itextomml/itextomml-1.6.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Native Ruby bindings to itex2MML, which converts itex equations to MathML"
+HOMEPAGE="https://golem.ph.utexas.edu/~distler/blog/itex2MML.html"
+
+LICENSE="|| ( GPL-2+ MPL-1.1 LGPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+#Tests don't fail here
+RESTRICT="test"
+
+each_ruby_test() {
+ ${RUBY} test/test_itextomml.rb || die
+}