summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-04-18 08:01:56 +0200
committerHans de Graaff <graaff@gentoo.org>2017-04-18 08:01:56 +0200
commitaa8dd99a6f2408f7aaaa871fd04c3f295a13cb2d (patch)
treea32b692a8690433fdb4b572e50c1068f4d1fec28 /dev-ruby/hiera-eyaml
parentdev-ruby/facets: cleanup (diff)
downloadgentoo-aa8dd99a6f2408f7aaaa871fd04c3f295a13cb2d.tar.gz
gentoo-aa8dd99a6f2408f7aaaa871fd04c3f295a13cb2d.tar.bz2
gentoo-aa8dd99a6f2408f7aaaa871fd04c3f295a13cb2d.zip
dev-ruby/hiera-eyaml: add ruby22, fix tests to use correct ruby version
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/hiera-eyaml')
-rw-r--r--dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0.ebuild b/dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0.ebuild
index 6afd988b9266..05be0dd4b982 100644
--- a/dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0.ebuild
+++ b/dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby20 ruby21"
+USE_RUBY="ruby21 ruby22"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md CHANGES.md PLUGINS.md"
@@ -36,6 +36,12 @@ all_ruby_prepare() {
features/puppet.feature
}
+each_ruby_prepare() {
+ # Run tests with the correct ruby interpreter
+ sed -i -e 's:I run `eyaml:I run `'${RUBY}' '${S}'/bin/eyaml:' features/*.feature || die
+
+}
+
each_ruby_test() {
${RUBY} -S cucumber --format progress features || die
}