summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-07-16 07:27:20 +0200
committerHans de Graaff <graaff@gentoo.org>2019-07-16 08:33:17 +0200
commitac3f41a0de252dbdbdcfd780228339e3f436a276 (patch)
tree1269ea5fab60f6e411932a2edd45d73b535bc8ad /dev-ruby/hashdiff/hashdiff-1.0.0.ebuild
parentdev-ruby/hashdiff: amd64 stable (diff)
downloadgentoo-ac3f41a0de252dbdbdcfd780228339e3f436a276.tar.gz
gentoo-ac3f41a0de252dbdbdcfd780228339e3f436a276.tar.bz2
gentoo-ac3f41a0de252dbdbdcfd780228339e3f436a276.zip
dev-ruby/hashdiff: add 1.0.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/hashdiff/hashdiff-1.0.0.ebuild')
-rw-r--r--dev-ruby/hashdiff/hashdiff-1.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/hashdiff/hashdiff-1.0.0.ebuild b/dev-ruby/hashdiff/hashdiff-1.0.0.ebuild
new file mode 100644
index 000000000000..7782fdb1b28c
--- /dev/null
+++ b/dev-ruby/hashdiff/hashdiff-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple Hash extension to make working with nested hashes easier"
+HOMEPAGE="https://github.com/liufengyun/hashdiff"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+}