summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-12-24 11:57:37 +0100
committerHans de Graaff <graaff@gentoo.org>2023-12-24 12:00:16 +0100
commit9e9c001fd1e27f97e6132a87a0aba19444bcccf3 (patch)
tree365664e168315fc7e37332f04cd2e46b9ac3631e /dev-ruby/haml
parentapp-i18n/ibus-rime: keyword 1.5.0 for ~loong (diff)
downloadgentoo-9e9c001fd1e27f97e6132a87a0aba19444bcccf3.tar.gz
gentoo-9e9c001fd1e27f97e6132a87a0aba19444bcccf3.tar.bz2
gentoo-9e9c001fd1e27f97e6132a87a0aba19444bcccf3.zip
dev-ruby/haml: avoid need for coffee-script test dep
Bug: https://bugs.gentoo.org/890800 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/haml-6.2.3.ebuild5
-rw-r--r--dev-ruby/haml/haml-6.3.0.ebuild6
2 files changed, 11 insertions, 0 deletions
diff --git a/dev-ruby/haml/haml-6.2.3.ebuild b/dev-ruby/haml/haml-6.2.3.ebuild
index a4ac5c0cb899..50f99feda53c 100644
--- a/dev-ruby/haml/haml-6.2.3.ebuild
+++ b/dev-ruby/haml/haml-6.2.3.ebuild
@@ -49,6 +49,11 @@ all_ruby_prepare() {
test/test_helper.rb || die
# Remove tests that fails when RedCloth is available
rm -f test/haml/filters/markdown_test.rb || die
+ # Remove tests that require coffee-script (does not work with x32
+ # and coffee-script is obsolete anyway).
+ rm -f test/haml/filters/coffee_test.rb || die
+ sed -e '/describe.*coffee filter/,/^ end/ s:^:#:' \
+ -i test/haml/line_number_test.rb || die
}
each_ruby_test() {
diff --git a/dev-ruby/haml/haml-6.3.0.ebuild b/dev-ruby/haml/haml-6.3.0.ebuild
index a4ac5c0cb899..1f9d7e635988 100644
--- a/dev-ruby/haml/haml-6.3.0.ebuild
+++ b/dev-ruby/haml/haml-6.3.0.ebuild
@@ -49,6 +49,12 @@ all_ruby_prepare() {
test/test_helper.rb || die
# Remove tests that fails when RedCloth is available
rm -f test/haml/filters/markdown_test.rb || die
+
+ # Remove tests that require coffee-script (does not work with x32
+ # and coffee-script is obsolete anyway).
+ rm -f test/haml/filters/coffee_test.rb || die
+ sed -e '/describe.*coffee filter/,/^ end/ s:^:#:' \
+ -i test/haml/line_number_test.rb || die
}
each_ruby_test() {