summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-04 14:27:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-04 14:27:04 +0200
commit217730a60a538e7e1156dee0d3ac0bc0641a1780 (patch)
treebdd2cf3fd88301d23878fa9773c2e9ef443269f4 /dev-ros
parentx11-misc/xsensors: Version 0.80 (diff)
downloadgentoo-217730a60a538e7e1156dee0d3ac0bc0641a1780.tar.gz
gentoo-217730a60a538e7e1156dee0d3ac0bc0641a1780.tar.bz2
gentoo-217730a60a538e7e1156dee0d3ac0bc0641a1780.zip
dev-ros/geneus: allow pkg dupes
Closes: https://bugs.gentoo.org/740046 Closes: https://bugs.gentoo.org/740038 Closes: https://bugs.gentoo.org/740036 Closes: https://bugs.gentoo.org/740028 Closes: https://bugs.gentoo.org/739280 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/geneus/files/allow_dupes.patch13
-rw-r--r--dev-ros/geneus/geneus-3.0.0-r1.ebuild (renamed from dev-ros/geneus/geneus-3.0.0.ebuild)1
-rw-r--r--dev-ros/geneus/geneus-9999.ebuild1
3 files changed, 15 insertions, 0 deletions
diff --git a/dev-ros/geneus/files/allow_dupes.patch b/dev-ros/geneus/files/allow_dupes.patch
new file mode 100644
index 000000000000..60c79b7fb8d4
--- /dev/null
+++ b/dev-ros/geneus/files/allow_dupes.patch
@@ -0,0 +1,13 @@
+Index: geneus-3.0.0/src/geneus/geneus_main.py
+===================================================================
+--- geneus-3.0.0.orig/src/geneus/geneus_main.py
++++ geneus-3.0.0/src/geneus/geneus_main.py
+@@ -53,7 +53,7 @@ def usage(progname):
+ def get_pkg_map():
+ pkg_map = {}
+ for ws in workspaces.get_spaces():
+- pkgs = packages.find_packages(ws)
++ pkgs = packages.find_packages_allowing_duplicates(ws)
+ for pkg in pkgs.values():
+ # packages.find_packages(workspaces.get_spaces()) returns package in high-priority-first-order, so we should not overwirte package map which is already found
+ # https://github.com/ros-infrastructure/catkin_pkg/blob/fa4b136b16e2d2886ab97257684f6bff243edefb/src/catkin_pkg/workspaces.py#L43
diff --git a/dev-ros/geneus/geneus-3.0.0.ebuild b/dev-ros/geneus/geneus-3.0.0-r1.ebuild
index 3f4bbffd97ca..6143a01472c4 100644
--- a/dev-ros/geneus/geneus-3.0.0.ebuild
+++ b/dev-ros/geneus/geneus-3.0.0-r1.ebuild
@@ -15,3 +15,4 @@ IUSE=""
RDEPEND="dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/allow_dupes.patch" )
diff --git a/dev-ros/geneus/geneus-9999.ebuild b/dev-ros/geneus/geneus-9999.ebuild
index 3f4bbffd97ca..6143a01472c4 100644
--- a/dev-ros/geneus/geneus-9999.ebuild
+++ b/dev-ros/geneus/geneus-9999.ebuild
@@ -15,3 +15,4 @@ IUSE=""
RDEPEND="dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/allow_dupes.patch" )