summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-24 10:42:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-24 10:43:09 +0200
commit23819b04b47f6294a165acb7e3ae782094344631 (patch)
tree285ced833c3ab1651d00f5d2fc5ab96f9fa2cdd2 /dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild
parentdev-ros/visp_camera_calibration: Initial import. Ebuild by me. (diff)
downloadgentoo-23819b04b47f6294a165acb7e3ae782094344631.tar.gz
gentoo-23819b04b47f6294a165acb7e3ae782094344631.tar.bz2
gentoo-23819b04b47f6294a165acb7e3ae782094344631.zip
dev-ros/visp_hand2eye_calibration: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild')
-rw-r--r--dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild
new file mode 100644
index 000000000000..418297faec66
--- /dev/null
+++ b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="jade-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimates the camera position with respect to its effector using the ViSP library"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/image_proc
+ dev-ros/roscpp
+ dev-ros/sensor_msgs
+ dev-ros/visp_bridge
+ dev-ros/visp_tracker
+ sci-libs/ViSP:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-jade-${PV}/${ROS_SUBDIR}"
+fi