summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 16:17:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:30 +0200
commitd7c72e82712dd36a7cde4a9fa3688229d3e63d7a (patch)
tree8fb06888d4a902ad3b603f57fb422ea5a7383c83 /dev-ros/test_roslaunch/test_roslaunch-9999.ebuild
parentdev-ros/roslaunch: Install noop.launch. (diff)
downloadgentoo-d7c72e82712dd36a7cde4a9fa3688229d3e63d7a.tar.gz
gentoo-d7c72e82712dd36a7cde4a9fa3688229d3e63d7a.tar.bz2
gentoo-d7c72e82712dd36a7cde4a9fa3688229d3e63d7a.zip
dev-ros/test_roslaunch: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/test_roslaunch/test_roslaunch-9999.ebuild')
-rw-r--r--dev-ros/test_roslaunch/test_roslaunch-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/test_roslaunch/test_roslaunch-9999.ebuild b/dev-ros/test_roslaunch/test_roslaunch-9999.ebuild
new file mode 100644
index 000000000000..665859925fc0
--- /dev/null
+++ b/dev-ros/test_roslaunch/test_roslaunch-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roslaunch"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/roslaunch[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ )
+"