summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-17 12:17:24 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-17 13:46:32 +0200
commit0cf856ef2671664d95c1a809c16f02aa9dd24ed7 (patch)
tree1bf59f25d60109d9c199c2a97e8404e3f72f7057 /dev-ros/test_rosgraph/test_rosgraph-1.13.2.ebuild
parentdev-ros/test_roscpp: Bump to 1.13.2. (diff)
downloadgentoo-0cf856ef2671664d95c1a809c16f02aa9dd24ed7.tar.gz
gentoo-0cf856ef2671664d95c1a809c16f02aa9dd24ed7.tar.bz2
gentoo-0cf856ef2671664d95c1a809c16f02aa9dd24ed7.zip
dev-ros/test_rosgraph: Bump to 1.13.2.
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-ros/test_rosgraph/test_rosgraph-1.13.2.ebuild')
-rw-r--r--dev-ros/test_rosgraph/test_rosgraph-1.13.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/test_rosgraph/test_rosgraph-1.13.2.ebuild b/dev-ros/test_rosgraph/test_rosgraph-1.13.2.ebuild
new file mode 100644
index 000000000000..a74f6b7bd3cb
--- /dev/null
+++ b/dev-ros/test_rosgraph/test_rosgraph-1.13.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosgraph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rostest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rosgraph[${PYTHON_USEDEP}] )
+"