summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 15:13:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 15:26:41 +0200
commite2775da076b704a7830d74ea0beefd3c36811828 (patch)
tree2864666167361d6354629f0db3dcbd1d8fe963ef /dev-ros/rqt_topic
parentdev-ros/rqt_web: Remove old (diff)
downloadgentoo-e2775da076b704a7830d74ea0beefd3c36811828.tar.gz
gentoo-e2775da076b704a7830d74ea0beefd3c36811828.tar.bz2
gentoo-e2775da076b704a7830d74ea0beefd3c36811828.zip
dev-ros/rqt_topic: bump to 0.4.12
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_topic')
-rw-r--r--dev-ros/rqt_topic/Manifest1
-rw-r--r--dev-ros/rqt_topic/rqt_topic-0.4.12.ebuild24
-rw-r--r--dev-ros/rqt_topic/rqt_topic-9999.ebuild5
3 files changed, 27 insertions, 3 deletions
diff --git a/dev-ros/rqt_topic/Manifest b/dev-ros/rqt_topic/Manifest
index 93d17ba6fd8f..0ea3dd2b7738 100644
--- a/dev-ros/rqt_topic/Manifest
+++ b/dev-ros/rqt_topic/Manifest
@@ -1,2 +1,3 @@
DIST rqt_topic-0.4.10.tar.gz 8907 BLAKE2B 92343432ddf3b2bd9dff600f088935ca6bceac0239f2818b9a5601a2702bac52c13526571c0be454c41dfe14f2d6baab48e6f95f004c233f474d5fc6ac943423 SHA512 d16c882091d7d2f5701a399faca4dfd5331bbf66b84222cfafcdfc8b362ccff667b9d13bfc2143d41b5d2261b98dde4e0e967c7123ec06b390c80b846a4beae0
+DIST rqt_topic-0.4.12.tar.gz 9104 BLAKE2B e40341efb53c25cadbf4143f73f8c36ffb5635212f1f4f26f937d4bbfb7ca9b70a596dab98ad1a941ae72e26e86741893a52ca22b0353e36bfbe5a016c675836 SHA512 1e124e10aade7150c4f0599ec0aba04a0bee25253318a4cc99d03164575ba79d4a8cbef170b527c5209989c480d9ce6d00c4267d96976500fcc9f9ba6fb11ba7
DIST rqt_topic-0.4.9.tar.gz 8794 BLAKE2B c239e6a54bdcbe4bc2c55bd08a74d523399478ba19b2502f9f75038e2fa7ff949f3e0fd76ec25a3443a037f975eb04625fe37e7fa51240022cac28d979337ebb SHA512 ca7b9a9459406dbafcf58b23fe6695b7f5627326cf0c5f2b5d5bb61475c34200181d4702270a6bad59e23ea0706463e15839624d128f063db167cc5fb60182b9
diff --git a/dev-ros/rqt_topic/rqt_topic-0.4.12.ebuild b/dev-ros/rqt_topic/rqt_topic-0.4.12.ebuild
new file mode 100644
index 000000000000..414b58def1e1
--- /dev/null
+++ b/dev-ros/rqt_topic/rqt_topic-0.4.12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_topic"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying debug information about ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_topic/rqt_topic-9999.ebuild b/dev-ros/rqt_topic/rqt_topic-9999.ebuild
index bf621ebec809..414b58def1e1 100644
--- a/dev-ros/rqt_topic/rqt_topic-9999.ebuild
+++ b/dev-ros/rqt_topic/rqt_topic-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
KEYWORDS="~amd64"
ROS_REPO_URI="https://github.com/ros-visualization/rqt_topic"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin