summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-08 14:00:46 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-08 14:22:20 +0200
commitc028bbab08c609da6143187f513bf5a009628872 (patch)
tree643511da1a043507ac208abac753082d91142385 /dev-ros/rostime/rostime-0.6.10.ebuild
parentdev-ros/cpp_common: Bump to 0.6.10. (diff)
downloadgentoo-c028bbab08c609da6143187f513bf5a009628872.tar.gz
gentoo-c028bbab08c609da6143187f513bf5a009628872.tar.bz2
gentoo-c028bbab08c609da6143187f513bf5a009628872.zip
dev-ros/rostime: Bump to 0.6.10.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros/rostime/rostime-0.6.10.ebuild')
-rw-r--r--dev-ros/rostime/rostime-0.6.10.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rostime/rostime-0.6.10.ebuild b/dev-ros/rostime/rostime-0.6.10.ebuild
new file mode 100644
index 000000000000..6d97b2f7c4f5
--- /dev/null
+++ b/dev-ros/rostime/rostime-0.6.10.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Time and Duration implementations for C++ libraries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/cpp_common
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"