summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-28 12:42:07 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-28 14:28:45 +0100
commita069c404e2a34a71686aa0b54052dde22fc27a34 (patch)
tree91e2c75d1a6f435e1e139dbda365b94ff66338f6 /dev-ros/rosserial_python/rosserial_python-0.7.5.ebuild
parentdev-ros/rosserial_msgs: Bump to 0.7.5. (diff)
downloadgentoo-a069c404e2a34a71686aa0b54052dde22fc27a34.tar.gz
gentoo-a069c404e2a34a71686aa0b54052dde22fc27a34.tar.bz2
gentoo-a069c404e2a34a71686aa0b54052dde22fc27a34.zip
dev-ros/rosserial_python: Bump to 0.7.5.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ros/rosserial_python/rosserial_python-0.7.5.ebuild')
-rw-r--r--dev-ros/rosserial_python/rosserial_python-0.7.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosserial_python/rosserial_python-0.7.5.ebuild b/dev-ros/rosserial_python/rosserial_python-0.7.5.ebuild
new file mode 100644
index 000000000000..ae37a0f34643
--- /dev/null
+++ b/dev-ros/rosserial_python/rosserial_python-0.7.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A Python-based implementation of the ROS serial protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"