summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-02-02 15:07:51 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-02-02 15:28:24 +0100
commit0a1274990889d28036b1c53130f56391bd2f6350 (patch)
tree0d9d31758f9a4e9f7a7d95d4d6652b6e6474547a /dev-ros/mavros/mavros-1.5.2.ebuild
parentdev-ros/libmavconn: Bump to 1.5.2. (diff)
downloadgentoo-0a1274990889d28036b1c53130f56391bd2f6350.tar.gz
gentoo-0a1274990889d28036b1c53130f56391bd2f6350.tar.bz2
gentoo-0a1274990889d28036b1c53130f56391bd2f6350.zip
dev-ros/mavros: Bump to 1.5.2.
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/mavros/mavros-1.5.2.ebuild')
-rw-r--r--dev-ros/mavros/mavros-1.5.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/mavros/mavros-1.5.2.ebuild b/dev-ros/mavros/mavros-1.5.2.ebuild
new file mode 100644
index 000000000000..6d42a584d799
--- /dev/null
+++ b/dev-ros/mavros/mavros-1.5.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink extendable communication node for ROS"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/angles
+ dev-ros/libmavconn
+ dev-ros/rosconsole_bridge
+ dev-libs/boost:=
+ dev-ros/eigen_conversions
+ sci-geosciences/GeographicLib
+ >=dev-ros/mavlink-gbp-release-2020.9.10
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavros_msgs-${PV}[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"