summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 18:21:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 18:31:01 +0200
commit2df5c164e499414287dcf472aeca2222060063fd (patch)
tree6128000fa9bf3e1a9b75be62af00e83fd30a9fe7 /dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild
parentdev-ros/hector_imu_tools: Bump to 0.4.1. (diff)
downloadgentoo-2df5c164e499414287dcf472aeca2222060063fd.tar.gz
gentoo-2df5c164e499414287dcf472aeca2222060063fd.tar.bz2
gentoo-2df5c164e499414287dcf472aeca2222060063fd.zip
dev-ros/hector_map_server: Bump to 0.4.1.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild')
-rw-r--r--dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild b/dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild
new file mode 100644
index 000000000000..d315b87686ab
--- /dev/null
+++ b/dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Service for retrieving the map, as well as for raycasting based obstacle queries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/hector_map_tools
+ dev-ros/hector_marker_drawing
+ dev-ros/tf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"