summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-09 22:17:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-09 22:17:11 +0200
commit8fafb3271bb1a83928e492a18f8a2a037b56dc44 (patch)
tree2d55a73e6fcf3e36e9e75cf8a7bfe20c0ddc82dd /dev-qt/qtwebengine
parentmedia-radio/gpredict: Drop old (diff)
downloadgentoo-8fafb3271bb1a83928e492a18f8a2a037b56dc44.tar.gz
gentoo-8fafb3271bb1a83928e492a18f8a2a037b56dc44.tar.bz2
gentoo-8fafb3271bb1a83928e492a18f8a2a037b56dc44.zip
dev-qt/qtwebengine: Fix build without dev-qt/qtlocation
Thanks-to: Jimi Huotari <chiitoo@gentoo.org> Tested-by: josef64 (via irc #gentoo-qt) Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-qt/qtwebengine')
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.11.0-fix-build-w-o-qtlocation.patch56
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.11.0_rc.ebuild2
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.11.0-fix-build-w-o-qtlocation.patch b/dev-qt/qtwebengine/files/qtwebengine-5.11.0-fix-build-w-o-qtlocation.patch
new file mode 100644
index 000000000000..2c5012ee34b4
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.11.0-fix-build-w-o-qtlocation.patch
@@ -0,0 +1,56 @@
+From 383ee1aa19b7b72c686d70f34bc9c377a51aaf5e Mon Sep 17 00:00:00 2001
+From: Allan Sandfeld Jensen <allan.jensen@qt.io>
+Date: Wed, 9 May 2018 13:23:17 +0200
+Subject: [PATCH] Fix build without qtlocation
+
+Change-Id: I81ac6fcf14563a6d093c51d93754d438992ee52a
+---
+ src/core/content_browser_client_qt.cpp | 10 +++++++++-
+ 1 file changed, 9 insertions(+), 1 deletion(-)
+
+diff --git a/src/core/content_browser_client_qt.cpp b/src/core/content_browser_client_qt.cpp
+index 30ec43ca0..3878bd1bf 100644
+--- a/src/core/content_browser_client_qt.cpp
++++ b/src/core/content_browser_client_qt.cpp
+@@ -68,6 +68,7 @@
+ #include "content/public/common/main_function_params.h"
+ #include "content/public/common/service_names.mojom.h"
+ #include "content/public/common/url_constants.h"
++#include "device/geolocation/public/cpp/location_provider.h"
+ #include "mojo/public/cpp/bindings/binding.h"
+ #include "mojo/public/cpp/bindings/binding_set.h"
+ #include "printing/features/features.h"
+@@ -93,7 +94,6 @@
+ #include "certificate_error_controller_p.h"
+ #include "desktop_screen_qt.h"
+ #include "devtools_manager_delegate_qt.h"
+-#include "location_provider_qt.h"
+ #include "media_capture_devices_dispatcher.h"
+ #include "net/network_delegate_qt.h"
+ #include "net/qrc_protocol_handler_qt.h"
+@@ -123,6 +123,10 @@
+ #include "renderer_host/pepper/pepper_host_factory_qt.h"
+ #endif
+
++#if defined(QT_USE_POSITIONING)
++#include "location_provider_qt.h"
++#endif
++
+ #include <QGuiApplication>
+ #include <QLocale>
+ #ifndef QT_NO_OPENGL
+@@ -737,7 +741,11 @@ bool ContentBrowserClientQt::CanCreateWindow(
+
+ std::unique_ptr<device::LocationProvider> ContentBrowserClientQt::OverrideSystemLocationProvider()
+ {
++#if defined(QT_USE_POSITIONING)
+ return base::WrapUnique(new LocationProviderQt());
++#else
++ return nullptr;
++#endif
+ }
+
+ scoped_refptr<net::URLRequestContextGetter> GetSystemRequestContextOnUIThread()
+--
+2.16.3
+
diff --git a/dev-qt/qtwebengine/qtwebengine-5.11.0_rc.ebuild b/dev-qt/qtwebengine/qtwebengine-5.11.0_rc.ebuild
index 32064b192b08..735be56a730c 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.11.0_rc.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.11.0_rc.ebuild
@@ -77,6 +77,8 @@ DEPEND="${RDEPEND}
pax_kernel? ( sys-apps/elfix )
"
+PATCHES+=( "${FILESDIR}/${PN}-5.11.0-fix-build-w-o-qtlocation.patch" )
+
src_prepare() {
use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.9.3-paxmark-mksnapshot.patch" )
use system-icu && has_version ">=dev-libs/icu-59" && \