summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-06-04 04:16:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-06-04 15:30:47 -0400
commit9a4a1d3ef0f4846b3aac5f56bcd80c721291103c (patch)
tree7b1141a73dff85842eae58ac519d396c45f05240 /dev-qt/qtvirtualkeyboard
parentdev-qt/qttranslations: add 6.8.9999 (diff)
downloadgentoo-9a4a1d3ef0f4846b3aac5f56bcd80c721291103c.tar.gz
gentoo-9a4a1d3ef0f4846b3aac5f56bcd80c721291103c.tar.bz2
gentoo-9a4a1d3ef0f4846b3aac5f56bcd80c721291103c.zip
dev-qt/qtvirtualkeyboard: add 6.8.9999
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtvirtualkeyboard')
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.8.9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.8.9999.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.8.9999.ebuild
new file mode 100644
index 000000000000..a6537989835b
--- /dev/null
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.8.9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+IUSE="+spell"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtsvg-${PV}:6
+ spell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(qt_feature spell hunspell)
+ -DINPUT_vkb_handwriting=no # neither cerence nor myscript are packaged
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # rarely randomly(?) fails even with -j1
+ tst_layoutfilesystem
+ )
+
+ if use spell && has_version app-dicts/myspell-en; then
+ # 99% pass but minor sub-tests fail with myspell-en, needs looking into
+ ewarn "Warning: notable tests were skipped due to ${_} being installed"
+ CMAKE_SKIP_TESTS+=(
+ tst_inputpanel
+ tst_inputpanelcontrols2
+ )
+ else
+ einfo "tst_inputpanel can take >5mins, not known to actually hang"
+ fi
+
+ qt6-build_src_test
+}