summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-28 08:28:31 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-28 09:07:41 -0500
commit8c975b160438b166ceae2d7d0f3b87d1934c723f (patch)
tree8ff22c5f3e7bbe0d8643867b5251a832a01fa18a /dev-qt/qtserialbus/qtserialbus-6.7.9999.ebuild
parentkde-frameworks/oxygen-icons: add 6.0.0 (diff)
downloadgentoo-8c975b160438b166ceae2d7d0f3b87d1934c723f.tar.gz
gentoo-8c975b160438b166ceae2d7d0f3b87d1934c723f.tar.bz2
gentoo-8c975b160438b166ceae2d7d0f3b87d1934c723f.zip
dev-qt/qtserialbus: new slot, add 6.6.2:6 + live
Nothing special (same as Qt5) and tests pass.. albeit it does need extras to cleanup junk it installs when tests are enabled. It would be possible to make qtserialport optional by using cmake_use_find_package but unsure how much sense this makes. Given Qt5 didn't, not going to bother unless someone using this package actually wants to skip this dependency. Note that this has no revdeps neither for Qt5 nor Qt6, but some users apparently need it and the package itself is simple. Closes: https://bugs.gentoo.org/925517 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtserialbus/qtserialbus-6.7.9999.ebuild')
-rw-r--r--dev-qt/qtserialbus/qtserialbus-6.7.9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qtserialbus/qtserialbus-6.7.9999.ebuild b/dev-qt/qtserialbus/qtserialbus-6.7.9999.ebuild
new file mode 100644
index 000000000000..83df0a8835c0
--- /dev/null
+++ b/dev-qt/qtserialbus/qtserialbus-6.7.9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt module to access CAN, ModBus, and other industrial serial buses and protocols"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ ~dev-qt/qtserialport-${PV}:6
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6SerialBus/*TestCanBusPlugin*.cmake
+ "${D}${QT6_MKSPECSDIR}"/modules/qt_plugin_qttestcanbus.pri
+ "${D}${QT6_PLUGINDIR}"/canbus/libqttestcanbus.*
+ "${D}${QT6_PLUGINDIR}"/canbus/objects-*/
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}